summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/cmd2
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.4.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index d598def10f11..d485afb46da7 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1,5 @@
DIST cmd2-2.3.3.tar.gz 675880 BLAKE2B 216b10d7a1d2eb78106e5af51a6c996ea22ff8ef13503ace6019978152f63d5015e61ab911a839703d2b3506fea4e709d507d147b2af259cf933ad628e52be22 SHA512 30d7a82a1c3d23431a40a7e99f10a4c23227e9ab073ab1d7fd83e516f54e9c90bda10e6072b50c0a2ca435498c1060e06b32a550409721899e28d2662995a8b8
+DIST cmd2-2.4.0.tar.gz 680118 BLAKE2B 09f4893db7587dce9fd59103f8a1ef54c2b61248dd4aed313a90a390bb50e8927ef7a11dc5ca3af90b5ccf36ce16e0e18f3b555cc961a8c6862f7b8131f190ae SHA512 4ecd4c71294bee86f02b39a588c42a7232309db54459c950f77734926dedc3ec273237b9615bab6ef8a499c65442e3d6f7d2e9f159ccca021db0b450435ffbc0
EBUILD cmd2-2.3.3.ebuild 1396 BLAKE2B 2a14076f2fb23f65fa8a50330df0c89c90aa33a9feb989f2782c6ec24a56556f28f7233ef0b682cdc9e4a3de1bb3d77fce380598d7cc1af9036aeea272457747 SHA512 e2c80c7bf92acff359ab6399154553d49de4314e5eb6714ec34dd7cb2657bc1c2902d0ac4dab269a9f5d087e0498ae2d51618fa8e4963c307b9c0ab3cd76f4c4
+EBUILD cmd2-2.4.0.ebuild 1485 BLAKE2B 7b006ebfdb5f20641db2dafd058467e97059b16d10ea7b1c9f0826d4b5657b0d3643a88d6994ed3d328381e910e40289fea0f85bc07816644cdd420e4106c478 SHA512 b7eeeb2e25eb4bbe57b4022c3de84e8b8c81ceb6f41eaf84294090222a11c3000e3e7a1d8afe9047df854e4d2f83f76dd95eccadb6929e42d82251cad7f70006
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.4.0.ebuild b/dev-python/cmd2/cmd2-2.4.0.ebuild
new file mode 100644
index 000000000000..26a05e90d1bf
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel) + which(1).
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ sys-apps/which
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest -p no:pytest-qt || die
+}