summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-06 17:28:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-06 17:28:09 +0100
commit3d1ec36f5f52760f2431b79c71dd9b7aaefbc9ee (patch)
tree687ad0fe326ee5fa1deeb22db8aa6b2fa8ce9d25 /dev-python/cmd2
parentefca56beb6bbb9547d49163cac02eac0b5c1f657 (diff)
gentoo auto-resync : 06:04:2023 - 17:28:09
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.4.2.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 3da479b446d5..8c227f05c4c9 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,5 +1,3 @@
-DIST cmd2-2.4.2.tar.gz 677598 BLAKE2B 38b767e70d42125639578a906a6bd0ac737ee1e3be2951b122f91a1a2bfe366ea23db2d7d7350842b667aca7614a3520057f689cb1c253d1c4b11e164c2ee4a1 SHA512 d70d264671db2783526c589199ff74cc70d53a4fbaa1d78636a508dbf8216aefab17f5764bf25b2b86e9c1413e0e61977819fbb0dec59d3209195df522d3fa5f
DIST cmd2-2.4.3.tar.gz 678661 BLAKE2B 806fbd6abc26737032dd6330ebabc1e5308e9082f9c98002845a54f1458d314feb476e4d491892e74cde16f5043c57495426ad50aaf3e7e8d0d938f0388db6e2 SHA512 1d440752262f38a742069e636373884edcc49c17ba17b21b24015cfe559b4df36b45ac9489f2f643897fbd38f54b8e6120daf07ef25d2f209af8a4ac8e4c0085
-EBUILD cmd2-2.4.2.ebuild 1501 BLAKE2B 70e3568ef23ceee0eca57daa793ff948edd6b3c0878fd618532ad69fc9b3441029d78aeb8ce063d0228270b5a01f471283b3f8a0ee76fe3fed37f24db8787afe SHA512 263a6ddacf30d7fa2cefb18d363546716747a3f4ee2410312568d5739320db9b30a17a5e60006deb273ad5ef0d0b9914db3b69505d3564c2d858ec9e9ef16eb3
EBUILD cmd2-2.4.3.ebuild 1454 BLAKE2B 529e751208feb74289e49847653db5ce328aa08c9b2fb24f905c86ed7f6fa8a4340c142236e42a34b71581ca39b14c748a976c5d28c8e9c5a8fb5b3f67b789a0 SHA512 9619090b1f90e8baf2a4d7ba4ea8435a23b9e35c88b79f928903322ca25d90a7463bab8af9656fdabba2847e7117940cc69e089dcc9d933c696e7121028c240e
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.4.2.ebuild b/dev-python/cmd2/cmd2-2.4.2.ebuild
deleted file mode 100644
index c540f3b3cef9..000000000000
--- a/dev-python/cmd2/cmd2-2.4.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="
- https://github.com/python-cmd2/cmd2/
- https://pypi.org/project/cmd2/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-# pyperclip uses clipboard backends in the following preference order:
-# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
-# klipper is known to be broken in Xvfb, and therefore causes test
-# failures. to avoid them, we must ensure that one of the backends
-# preferred to it is available (i.e. xclip or xsel).
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- || (
- x11-misc/xclip
- x11-misc/xsel
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e '/--cov/d' setup.cfg || die
-}
-
-src_test() {
- # tests rely on very specific text wrapping...
- local -x COLUMNS=80
- virtx distutils-r1_src_test
-}
-
-python_test() {
- epytest -p no:pytest-qt || die
-}