summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
commit21dbcce41990b13f301240313be05c8d013a9258 (patch)
tree933b3c51d46dc15fefe62b03a4f41c85b7e9bb44 /dev-python/cmd2
parente53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (diff)
gentoo auto-resync : 28:01:2023 - 08:51:03
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.4.3.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 1566de5f9d7b..824457b2d635 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1,5 @@
DIST cmd2-2.4.2.tar.gz 677598 BLAKE2B 38b767e70d42125639578a906a6bd0ac737ee1e3be2951b122f91a1a2bfe366ea23db2d7d7350842b667aca7614a3520057f689cb1c253d1c4b11e164c2ee4a1 SHA512 d70d264671db2783526c589199ff74cc70d53a4fbaa1d78636a508dbf8216aefab17f5764bf25b2b86e9c1413e0e61977819fbb0dec59d3209195df522d3fa5f
+DIST cmd2-2.4.3.tar.gz 678661 BLAKE2B 806fbd6abc26737032dd6330ebabc1e5308e9082f9c98002845a54f1458d314feb476e4d491892e74cde16f5043c57495426ad50aaf3e7e8d0d938f0388db6e2 SHA512 1d440752262f38a742069e636373884edcc49c17ba17b21b24015cfe559b4df36b45ac9489f2f643897fbd38f54b8e6120daf07ef25d2f209af8a4ac8e4c0085
EBUILD cmd2-2.4.2.ebuild 1501 BLAKE2B adbc95a0581483d6545c7dd3364ca9bbc7e3805558129c345edda4e7612d4c56f96da449fe00d1979c2f10d410646cbc473e4664c2e09334ebd107706f0b24cd SHA512 7431a31feab279e9c198381d34a924353a6d4431704698dacc4d1c735af196447211ba134c84d1577f008984944ff9afcd1834f75065cbdfd224f7789723ea6f
+EBUILD cmd2-2.4.3.ebuild 1506 BLAKE2B 661bb5218f0a6809a8fa25969bab9c330785c2ce532ae7bd0ffa9b8b8a4b87df7877d03703b1e9098cb88b7450ee8b2b5e6e6a41699ea3d8f7a2a450042910e5 SHA512 de355201ddb35ca3ed7b6cd626d49988da4fc95c525cf333d66a7221eea93412724af367d1ee559ff82ee2dc5a6b8ed05bc6ee4006fd4fe4e67582fc08185924
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.4.3.ebuild b/dev-python/cmd2/cmd2-2.4.3.ebuild
new file mode 100644
index 000000000000..aa52347efcf8
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.4.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="
+ https://github.com/python-cmd2/cmd2/
+ https://pypi.org/project/cmd2/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel).
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest -p no:pytest-qt || die
+}