summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-25 04:04:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-25 04:04:27 +0100
commitb11a5614cb96e70e116581c98abf286c2cf694ca (patch)
treeb602f03c26a8da259d67174441f0630d3fbbfa5d /dev-python/cmd2
parente7daa1f959ba2c720f36a6984f588098e68b15cd (diff)
gentoo auto-resync : 25:10:2024 - 04:04:26next
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.5.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 86bd6c88d4f1..bb4874761e4a 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1,5 @@
DIST cmd2-2.4.3.tar.gz 678661 BLAKE2B 806fbd6abc26737032dd6330ebabc1e5308e9082f9c98002845a54f1458d314feb476e4d491892e74cde16f5043c57495426ad50aaf3e7e8d0d938f0388db6e2 SHA512 1d440752262f38a742069e636373884edcc49c17ba17b21b24015cfe559b4df36b45ac9489f2f643897fbd38f54b8e6120daf07ef25d2f209af8a4ac8e4c0085
+DIST cmd2-2.5.0.tar.gz 688531 BLAKE2B b5b88faf2848b8941df70235c32451847c86dbc7953b960383e57fa1529d4d3c557d75a36010900f7702c68b3f46de1725fb4b74892073b0dcd975b4f880e9cb SHA512 7c04cb735624abdd8ba93aa7dd5155913fe6bd9f2021c58008a20e91c380fed87c1bb32b552be6b7ab47ceca49bc5dced9e31fe7a5a0b621475862b28216f4ee
EBUILD cmd2-2.4.3.ebuild 1449 BLAKE2B 048c82f691185fc1ec554da222c550b26e721a394a1d6ed415c7bc50d9d15d89af538efddb6a06436107ada2507c5837dfc57657947a4a730d77f910a0963341 SHA512 00381938df082bfa0aa824ac2eec95bebc45856d9419b0893292ef3cdb06ba1e22404aa4ca1fd6245bf995a2c2c4b56e7f248d9faa6daee3639bf4d606e9345e
+EBUILD cmd2-2.5.0.ebuild 1332 BLAKE2B b0d912a7d7d35e4148d4932635c8348fcd9b10ccb46a9758754c68d764aacf17789bf34ebfb3e30416cbdf870d512e64a0cb2a519188dca5c366b92611bf0fd3 SHA512 1a3c84a81e73d8bee162bb5f88b03034d9c3be4d1bf767bcada796dee1a94c501cd2ac189ee4dfc8f516eb35ae85fce4f7a32737184d87996690f28f5ea9850b
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.5.0.ebuild b/dev-python/cmd2/cmd2-2.5.0.ebuild
new file mode 100644
index 000000000000..820c48bb0ffa
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="
+ https://github.com/python-cmd2/cmd2/
+ https://pypi.org/project/cmd2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel).
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # TODO: tests_isolated?
+ epytest -o addopts= -p pytest_mock tests || die
+}