summaryrefslogtreecommitdiff
path: root/dev-python/cloudscraper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 12:20:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 12:20:34 +0000
commit79e2fe7ce5d8192f7ddc9f57d4fb11bd1231f041 (patch)
tree214e48e63c0393badb2c99be0bc323c046ee2a25 /dev-python/cloudscraper
parent30f491533785a455cdfbd05bb57f1f869a8e41bb (diff)
gentoo auto-resync : 10:01:2023 - 12:20:33
Diffstat (limited to 'dev-python/cloudscraper')
-rw-r--r--dev-python/cloudscraper/Manifest2
-rw-r--r--dev-python/cloudscraper/cloudscraper-1.2.68.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/cloudscraper/Manifest b/dev-python/cloudscraper/Manifest
index 325fa4e506cf..4660fb0e5984 100644
--- a/dev-python/cloudscraper/Manifest
+++ b/dev-python/cloudscraper/Manifest
@@ -1,3 +1,5 @@
DIST cloudscraper-1.2.65.gh.tar.gz 111946 BLAKE2B 7b53819ceb3349c9e8bc24cfd3138119b46bd88daa639d1c29b7e7477f0fc2cb323b3e485832236eadf48be76d16a2dde93cadffe594fc7b7d43b24651de45eb SHA512 e885e7e0b7e91318da4b6d65165961fbae27951be9b4f05af96e7eeaf1e28e1146af52c10bf0b769f07fc04016998eed9146ec92504a591d81434a101c6d6850
+DIST cloudscraper-1.2.68.gh.tar.gz 111952 BLAKE2B 69e896ad704ce776594fb89714bb75316ebff1b03387cba8575be6d60b496d18556690cfad109c2fa55c72ce3d91dcd21a21467a2d9820c579fea7482b688800 SHA512 42fa90127c6348c52a8327728683719966ae69c7b945cb9b485907e89e3b29b8053d31cd9cd4326e71ffd4c33e0fce20dd3d0e046fab62d89110eb4510535ad9
EBUILD cloudscraper-1.2.65.ebuild 1466 BLAKE2B 1bd63fb43f0baeb95e16af86e30f3e0334978609f79da270f5fcc15ac3bb6cd273994322d2ff4a20a7f4116f0900b3239336576b70bb2b5261bc9d0b683fc38d SHA512 92222bef3f07a87a430be869e93c69cb97266319243a4386979620a73f57967605371f63e971e1ee4488116cd8ae2544a4f4ca78c126b57f7329d6be2aceacf4
+EBUILD cloudscraper-1.2.68.ebuild 1522 BLAKE2B 59c80a32e6e6d8dd6f0200c67adf3e8b4b714c4bd37348343265e5f5862da62134f653738c15567a5480b9b3228dbedce7edc293125562ffe343677f8ce7519f SHA512 795aadc0f5b6928fc02f0e018e78bf55ed7c92906c7de6fa08a258df446700f4797e64643236ac051fff407a3215cfe209da3524c1b5987c4fcd8cf73ece3a14
MISC metadata.xml 749 BLAKE2B dd73d528bd6b2fd50230028ca8877783b315c9f3327ca3173b75a32ca7d1dc6135aa86e765f6d7b9929e6a84e5ce7f99a9c2a0ee4972c01e818f27b83719b5b8 SHA512 b36231ae7509d4ee146c4b0ba97aef6d9ee67db44741ba9f53e201f5f6b0392eaee3ce6e41c988ef9938c5e4b6dbe1fea10505319d40916e6b0bce5597dd790c
diff --git a/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild b/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild
new file mode 100644
index 000000000000..a1c5530419a1
--- /dev/null
+++ b/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A Python module to bypass Cloudflare's anti-bot page"
+HOMEPAGE="
+ https://github.com/VeNoMouS/cloudscraper/
+ https://pypi.org/project/cloudscraper/
+"
+SRC_URI="
+ https://github.com/VeNoMouS/cloudscraper/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/js2py[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ net-libs/nodejs
+ )
+"
+
+# These tests fail for no understanadble reason
+EPYTEST_DESELECT=(
+ "tests/test_cloudscraper.py::TestCloudScraper::test_bad_interpreter_js_challenge1_16_05_2020"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_bad_solve_js_challenge1_16_05_2020"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_Captcha_challenge_12_12_2019"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_reCaptcha_providers"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "brotli decompresssion support" "dev-python/brotlipy"
+
+ optfeature "js2py interpreter support" "dev-python/js2py"
+ optfeature "node.js interpreter support" "net-libs/nodejs"
+}