summaryrefslogtreecommitdiff
path: root/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 16:00:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 16:00:40 +0100
commit7f1592d914f244f1c2ab9e4bf84c003131f6d3b8 (patch)
tree7bce2dbb6156f707d739cb9fc044116fe4325dd6 /dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
parent5a2a5572ac35843b9cd1c9369bd96e117647d24f (diff)
gentoo auto-resync : 16:10:2023 - 16:00:40
Diffstat (limited to 'dev-python/cloudpickle/cloudpickle-3.0.0.ebuild')
-rw-r--r--dev-python/cloudpickle/cloudpickle-3.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild b/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
new file mode 100644
index 000000000000..a6afca0f935c
--- /dev/null
+++ b/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extended pickling support for Python objects"
+HOMEPAGE="
+ https://github.com/cloudpipe/cloudpickle/
+ https://pypi.org/project/cloudpickle/
+"
+SRC_URI="
+ https://github.com/cloudpipe/cloudpickle/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH=${PYTHONPATH}:tests/cloudpickle_testpkg
+ # -s unbreaks some tests
+ # https://github.com/cloudpipe/cloudpickle/issues/252
+ epytest -s
+}