summaryrefslogtreecommitdiff
path: root/dev-python/cliff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 05:42:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 05:42:48 +0100
commit100b0ae24e9b0d0fb3071efea2078a3bdabe4e38 (patch)
tree637adb56b86839c41fcb217b9bbe37e022fa666d /dev-python/cliff
parent12de738b83927a4b71c3ad067edbb6279d15b368 (diff)
gentoo auto-resync : 10:05:2023 - 05:42:48
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest2
-rw-r--r--dev-python/cliff/cliff-4.3.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 31edf39b5440..fb102b291964 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,5 @@
DIST cliff-4.2.0.tar.gz 83168 BLAKE2B ac2d288ac3728f4266d61edb9b6aedc897e9020d3f8a74ebba4721530942a27335564c2a95406a4d6b5374df49e38bc0aa303d3aff12f83c91e48c59f13aa45f SHA512 6f0c31b49603be5289e6d4c9b2572862e977264df21dc14d976289c627909102d672ee8ffa5b6cd79b3a349158ff8f36444a2d2061e18eeb7121ce79b2d5719b
+DIST cliff-4.3.0.tar.gz 82652 BLAKE2B 8d4977e3541fd9de21fb637069abcb92cf38b07f47f0d61d329397ab9d42335f18faa6d7d13862b7f188632af39d46118d0f3ebfcf2475b67c258388aa4bbcc2 SHA512 b4ed6fcec05017c999d54188459aa93c9a35660b0ceb505525f22a6bb7632e3548e91d8dc00db381c314a3818be2a457b7aee3307da35915ea7519c1e13091a3
EBUILD cliff-4.2.0.ebuild 1120 BLAKE2B 2f6e955387b1412415974becd157303b0648c9cf5fdea47e6bfa8830e1e0e515a791586d7a92bbf0ceb1dff39bb761508687361d78f8b50a730a3579787d842f SHA512 0e81f7cfb53119c84e5707714f49f1822c2d42293e23d511aedbe4931edcb743f3983b529e33abe6c2c7974a111774524a69bbb862225ee9dfe82aafd07eb218
+EBUILD cliff-4.3.0.ebuild 1124 BLAKE2B c1047e0b82cf879a829cc5c965b1d83f595a7d6126c4532581c8c616dfef99b724a44b188d619f5c1d11b8b370457b1c724c7fcf2c21729bc6c7f1ab21e77d56 SHA512 2678c9220b5f77154ca2163dfbec1c783bbce6730d6d9da1cbc9be1da7f8f7a77eb91bddea94b9d46d7676cdf4ce4e1bd780467131cad6421a6523825a273d01
MISC metadata.xml 712 BLAKE2B 367482d2ee04af7b55c217aaa49b5784333f66b1a25dffc0bcf5b639c90d69df0002feac780e36ca7a7c40fd40be424c8116389fbaf9ad5547ffb7f2f5f34697 SHA512 dfcdcdb8f473a5f9caaf281f3c408b21c15dee411c71f45ac0c2f79d2ce2ab5aa29bc59d5fcb1ee13db033509b38c27a3b9d5c07b6bd20a10e9933632f9f5657
diff --git a/dev-python/cliff/cliff-4.3.0.ebuild b/dev-python/cliff/cliff-4.3.0.ebuild
new file mode 100644
index 000000000000..3969d97bb918
--- /dev/null
+++ b/dev-python/cliff/cliff-4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest