summaryrefslogtreecommitdiff
path: root/dev-python/cliff/cliff-4.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-18 22:13:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-18 22:13:50 +0100
commit6b36d02cbdfea303a1d9bf985b6e8c984c7ac3cf (patch)
tree5b12e13d34ece81eb6b5991db8928e24538287a2 /dev-python/cliff/cliff-4.3.0-r1.ebuild
parentae7f349673c9e013e85bbc65e873d3363467a293 (diff)
gentoo auto-resync : 18:05:2023 - 22:13:50
Diffstat (limited to 'dev-python/cliff/cliff-4.3.0-r1.ebuild')
-rw-r--r--dev-python/cliff/cliff-4.3.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/cliff/cliff-4.3.0-r1.ebuild b/dev-python/cliff/cliff-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..61dc58d0c27f
--- /dev/null
+++ b/dev-python/cliff/cliff-4.3.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.11.1[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest