summaryrefslogtreecommitdiff
path: root/dev-python/cliff/cliff-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
commit7c68db06bb531670c1261374c0133d652b476bd7 (patch)
tree5bbbde86ec021664b3c6dfaf90e1175f8378949c /dev-python/cliff/cliff-4.0.0.ebuild
parent0987983e8588d2819bb2ceb029792d511cee0bda (diff)
gentoo auto-resync : 12:08:2022 - 14:22:05
Diffstat (limited to 'dev-python/cliff/cliff-4.0.0.ebuild')
-rw-r--r--dev-python/cliff/cliff-4.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cliff/cliff-4.0.0.ebuild b/dev-python/cliff/cliff-4.0.0.ebuild
new file mode 100644
index 000000000000..8bf1ddb73cae
--- /dev/null
+++ b/dev-python/cliff/cliff-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest