summaryrefslogtreecommitdiff
path: root/dev-python/click
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/click
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest4
-rw-r--r--dev-python/click/click-8.0.0.ebuild27
-rw-r--r--dev-python/click/click-8.0.1.ebuild32
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index b9216ac37d59..712605a9df1e 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,3 +1,7 @@
DIST click-7.1.2.tar.gz 295757 BLAKE2B aea76d5378cfa49fe58a83132737d609d48b3d3a71ec65c0a8a144c7a0e244b5bdf0196ffe2150889b82edda20c3f1faa3c84a227fc9ef459a5a9646cff86129 SHA512 d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba
+DIST click-8.0.0.tar.gz 329520 BLAKE2B a3a5e299390c8223794c31fd0278367ed941923f81e73e2b4ac878ef670b156de9de4b8d539e1d0a968b8ff99764086b34ebf50d3afe3afa7060aeafc7ed8831 SHA512 656509d4eb49ce46738d09499a924a6064857d13995c0ec289b9a731c05165582c30fd4a8a09d0531ace77c217a9d4ba3f305ba2843c7879d90c84a78072046d
+DIST click-8.0.1.tar.gz 330890 BLAKE2B ae0a29bf1848e92c21ade72fb8ce08991c9edf6d5afb6d70a0dd85cdbfacffeac69a675dc0842566ae23ed8c666deac97879ad4611e8294ee1c6896ea2ddca8a SHA512 d93ec1d070dfa306733ee79893c64de9afcb0c7bf03d3f543dd697ef195f3a750828f77842a22886960a938740b92f0122962076ea52b911b87f7f75941a9032
EBUILD click-7.1.2-r1.ebuild 764 BLAKE2B d1d38b50a150be24f89380cf98233f141ca96c91e6dbc64153c8cfd6326b98098a174fb7ee58fb120957509b85262a056d7837a9e9f61639abb10d6707f6845a SHA512 ac8ba661a0f1664960eaf8748cfa1118e851ee5b2a4cd924b37742d6d09009dc7e4eaef10b08f1d796d47cdce0ba3483fc2809eefe0717111339327b14585c22
+EBUILD click-8.0.0.ebuild 772 BLAKE2B 788941e23f84686f11226b6a572f6307165d1411c0a5c92ce90e8ce3cf1bf3be7d6aec8b170b20fc11088f4bd3e69e57dd5c6d57827687978d60df9e08fca8be SHA512 23f560eca1f6ba2193aafbc62f291d06cd6f92d97a8cc0431d13866ad602bdfb28c16588f191111d8a262949db7d4b3ad09480d00ddc9f819b294be18d8f488b
+EBUILD click-8.0.1.ebuild 879 BLAKE2B 0337123dc9b645d023e8bca2b65f6d67f006b3f446294023ca43a602f5549858a26435aad908c82adcf6bbb3e65f201e210d92d53a530f8d73a37e74952bcce9 SHA512 9cca790a0526473695224d231ecc55c85c9a912a780bab2d585592aaeda61664d88802b062e8dfe449cc7cf0cb9827513347ef00a17d387828ca14f18b2ae6cf
MISC metadata.xml 332 BLAKE2B a41bc7699360c666ce286a0d9a44779fab5afa6e6ce99efec2ee65a5d8d534bf3ccd65d4b23a2f5d40fc3b1c04c3c7e078a8889a3030909e7cc3992eabecfcb3 SHA512 de78734678a4bafe5175228f6df58210c65eaf016efec93e65441109b280725c4994406d0f21f2ee22ca0f9e1e27e27f76b3a1db724dbbd5b958fc8d8410126f
diff --git a/dev-python/click/click-8.0.0.ebuild b/dev-python/click/click-8.0.0.ebuild
new file mode 100644
index 000000000000..6d9663b156cc
--- /dev/null
+++ b/dev-python/click/click-8.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click/click-8.0.1.ebuild b/dev-python/click/click-8.0.1.ebuild
new file mode 100644
index 000000000000..20a203289158
--- /dev/null
+++ b/dev-python/click/click-8.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}