summaryrefslogtreecommitdiff
path: root/dev-python/click
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 21:33:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 21:33:19 +0100
commit19e23b194d10e420ec050c4d8a6253aad17694b1 (patch)
tree44ef9c9c2f5433a2251428352e4c9afb877e2500 /dev-python/click
parentc74abf990d32765245eeb94b36ad4af642cae8c0 (diff)
gentoo auto-resync : 17:08:2023 - 21:33:19
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest2
-rw-r--r--dev-python/click/click-8.1.7.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index 21631cf3c14c..ae597768707b 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,3 +1,5 @@
DIST click-8.1.6.gh.tar.gz 341538 BLAKE2B 611619665a95be2ae590c2fdad403bc834fd43665df4418ab0fa5e55b4ea90600db8a1710e5c77bda3dc1a77e6b53393a52225730a4fe4bb874076569e4b1d96 SHA512 ae31e4b5666b7ab6638a12fd12088c5b5311a4f6913e3471aefdf2392cf47d4be6e745e09070d6f2e382fa92c4068c196e0109295d86953dd066f7619dfbd4cd
+DIST click-8.1.7.gh.tar.gz 341625 BLAKE2B 11acc52c1138945e2588019811c88c4edf492fe7de44a17e9e5b60f0ca503c22f877ff42b3384b95cf207995d8cd7c8c3c90b47be2bf2b3f4efc0d03ab883405 SHA512 a1cb115b90193d78f94ec2a6af563b089820517e6e0e4b71ea3d6c68304444d16db3597358c62e1757d9d05449996b7168a220eecde6ab4991367fdb6e74096f
EBUILD click-8.1.6.ebuild 957 BLAKE2B 2c150a87d554932e6f37b47c886e6be1badd33e5a265f2caca2c3678854e7fc0d45ead3fad2e61e6908a7a120be20e69ff10cacae8c03e1cc53db053120492fc SHA512 7ce682253ccf7d1199c89aba91c843bac296f0e84222ba489af75f628310791db6b81c9d34dbd03f82b86b76d0b9de102685f88a5246ee7955bd8d0fd53db682
+EBUILD click-8.1.7.ebuild 965 BLAKE2B 315c47b0569c059e167a3604200131118ac0881e429be6f68dc7583ce6aa8ebd88d6f456e49cbf86cdb740daa3fcb5ca1fd808004e1f9ac6041586f349fbd237 SHA512 f978f898f939b9cdea079793ac43d8f3d06c9790ec66b578c0cb8b300973a6f3574649cbaf7e8f1503d61d9e0ba0729c49782ac9e69b36fc8de971df39ccb94c
MISC metadata.xml 386 BLAKE2B e460c7d70bbd848cd239d9e1ba5dc234c7de2a2bc0c77bfefb6aed1fa6d954de18508d4db44e77495f90a141180fa2602b15d3699aaaa99a48520a7e37a098f4 SHA512 ef8dd0545e92bb8fdc107fd6170068d35f44abad698226ea4724c450aebc0f32c76eb90b9fc936f9c85b8a93637f6006e889796e2bb3b7da5f57c1419f6b3794
diff --git a/dev-python/click/click-8.1.7.ebuild b/dev-python/click/click-8.1.7.ebuild
new file mode 100644
index 000000000000..0cf462f36528
--- /dev/null
+++ b/dev-python/click/click-8.1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://github.com/pallets/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log-cabinet \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}