summaryrefslogtreecommitdiff
path: root/dev-python/click-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/click-plugins
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/click-plugins')
-rw-r--r--dev-python/click-plugins/Manifest1
-rw-r--r--dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/click-plugins/Manifest b/dev-python/click-plugins/Manifest
index 93d9f2d82394..0ec10dad7320 100644
--- a/dev-python/click-plugins/Manifest
+++ b/dev-python/click-plugins/Manifest
@@ -1,3 +1,4 @@
DIST click-plugins-1.1.1.tar.gz 8164 BLAKE2B 48d75b9445b72dca41516fe81d02c6fad8089630c0d49963f559a847b90c7897c8db64773c4ec5f4c162d0f2f4fdd14fe212d485765d38977145fd32acdd0dcb SHA512 bbd838f50603ac4e76daf3535fd5d27a17e17549addbc8b582df6d6193b4f07d743101ce52f0b71f326995fdfeac159805025770350ca2e7697f212dce0c4b1a
+EBUILD click-plugins-1.1.1-r1.ebuild 540 BLAKE2B 8da9bc60de21984d40c3fb8ac8337935e0706ee48b26c0afde6a81619cbacf2d618ba28b469fd9b8a175a2731c0e08573f0172d35b7bbc481e0a186569c66941 SHA512 d7bb5c065def293c979350cbd026c10c48b0739f6d7d52f855aa0e7357ffa279ca8e10d4b98ebeb99b31d144ddd933d5696402cbcadb78c5038e777d1f1c4f8b
EBUILD click-plugins-1.1.1.ebuild 555 BLAKE2B 457084a7f66e7cd1863910a779640d9b8c8957d6064edaa3f99d674351adf8f7c283df139293dd3f19a792577055c0e7d6e86020d9284073dab58955f57b4812 SHA512 4acc10428234995ccf7cde9465005e05a70301b6df617c32c2a8a4722f8fa51e30a4b3c5b200d386a5dc26d5a12d3528b28e4a040b1a350729d10550b6eb774d
MISC metadata.xml 311 BLAKE2B 979e8b892b9771bdac7ffa3a58e165097a70dfde354a5062316850ff72c4192148f053fe0be60ba6aa43434b757d15647c02682fc21f08dc986ef02f15232e59 SHA512 132f8fc7fbe5005f70578d5eab2f43ec62e322df618ce479d22958dcaa4c63d192506a7a9423978b1f850689717e32d2a78b883502cf1f43e24fb7a61bfad578
diff --git a/dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild b/dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..67293946200d
--- /dev/null
+++ b/dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module for click to enable registering CLI commands via setuptools entry-points"
+HOMEPAGE="https://github.com/click-contrib/click-plugins"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+distutils_enable_tests pytest