summaryrefslogtreecommitdiff
path: root/dev-python/click-help-colors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/click-help-colors
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/click-help-colors')
-rw-r--r--dev-python/click-help-colors/Manifest3
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.ebuild26
-rw-r--r--dev-python/click-help-colors/metadata.xml13
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
new file mode 100644
index 000000000000..199ecceff4b9
--- /dev/null
+++ b/dev-python/click-help-colors/Manifest
@@ -0,0 +1,3 @@
+DIST click-help-colors-0.9.tar.gz 100701 BLAKE2B 838507658aec9cea962d1f373bd771871837d1fe274c70fe4555efbd4e1825203d8728457c5836a482add26e86d4eed83b962811602864d43bf8174f49bd89cd SHA512 02cca02a5cec6b3b23fdeee4aef921cac1cf83d85bea8eb04dd100955dc27b2e4d098bad2f49694c0aa6548135fb979a1fd054525dcec27077f461a034d62a87
+EBUILD click-help-colors-0.9.ebuild 612 BLAKE2B 093296e1bc0a492edcc6d6c29c1635d63352f2903f48103d1c0012daf5fe6429f7e5612da687810d4ae890542b3c260d9e431908522ffaa6d7859c5069d8e3ac SHA512 49175a08eda7d01d1f6211ac6021862a8b1f9e716b9d2e972530dadecdb225c32fb191906e55e8ea8b952c5392db28904ee40eb4b68ab13ff6778f2d8d422ebd
+MISC metadata.xml 420 BLAKE2B b7f9eb67dcb6e7e6f2de54e0f8d96974147d92a5839fffb5d68201dcaad1ff600caae1971d9d0608366fafebaa270d8aa750bee3e51fa3a97ca12c2fdf6842dc SHA512 b1fce393231a5053ff90f5163e2a4788500f0819a0623f2b8a0df391ce37f085d11ae69d7db41235195a31bc83c6ff729058d6ac0aa66d155a1a652f485d65be
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.ebuild
new file mode 100644
index 000000000000..0f16c35209b3
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="https://github.com/click-contrib/click-help-colors"
+SRC_URI="https://github.com/click-contrib/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="<dev-python/click-9[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click-help-colors/metadata.xml b/dev-python/click-help-colors/metadata.xml
new file mode 100644
index 000000000000..4f878dd813d2
--- /dev/null
+++ b/dev-python/click-help-colors/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">click-contrib/click-help-colors</remote-id>
+ <remote-id type="pypi">click-help-colors</remote-id>
+ </upstream>
+</pkgmetadata>