summaryrefslogtreecommitdiff
path: root/dev-python/click-help-colors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
commit6cdde4bf2702fac82ba7163fe9f922e7fa0b9a66 (patch)
tree876fe918d1abfd24cf9323208d2929b94a47cfc7 /dev-python/click-help-colors
parentce89e807ecd2194613ad6e6bcee8cf95e982ad1a (diff)
gentoo auto-resync : 18:11:2023 - 17:04:41
Diffstat (limited to 'dev-python/click-help-colors')
-rw-r--r--dev-python/click-help-colors/Manifest2
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
index 116f8387f4df..5ca9443088cf 100644
--- a/dev-python/click-help-colors/Manifest
+++ b/dev-python/click-help-colors/Manifest
@@ -1,5 +1,7 @@
DIST click-help-colors-0.9.2.gh.tar.gz 130204 BLAKE2B ac8f4b0369f5a1d71115e92d84b6b2229f955c74d2ca443aa98319316d5a6d944d29ce4979fc2d8cd03dd5916c4ab6b0870172f2982a83df6d510e51b779ef60 SHA512 1092b256339faf7399274c7cd525895f53e57f31e5d0d4a7068e0fa29e7757d14881a2fd980c501a7277a25ece760623fa4c967c60302359c880899c8a01652f
DIST click-help-colors-0.9.3.gh.tar.gz 131170 BLAKE2B 612789519501858ee8ed415b274b426273b6e4c48b9f650f966f0ee2774c97531c5bbbbf7e0e6edb08f50821635212a04f920a2a26d8897db9dd9413c3999bfd SHA512 7d3708ea710de41baca075468e5d434f5536d04ceb1092085c46cccc31f58d16f6ed1095efca1d9dc6bd1e5532a41e8bde4343d8197744fca58642dd80a03c59
+DIST click-help-colors-0.9.4.gh.tar.gz 131221 BLAKE2B cb6e5818eddf8ac757206b537053368be672382133bd6a1de65653b671c8780e991b437a31313740303b0e9d6d84eccb04b84577149311c3a27ad9fdaae4c5a4 SHA512 9dd7cc972834e4711cd9f3e957ab50aaa9e7c3e983a98d2d35603a548c85c9c3d3104f567cd13250eb621b67d138b7b94771216dc8323a281fe4fee51d7b752e
EBUILD click-help-colors-0.9.2.ebuild 697 BLAKE2B 71432111e3e6174be06ba4bb41163f79c041507fc22ca0d96c5682aa7af3b270d6849dd58594ed2576cca5a714935ba2842ea6e9dc61450abeb8f275843f408a SHA512 f93bda84de3d394bea3b2bdf87e9151f3a212258d5627a4b3538e638804e35245896d7e625d861745e86ac89e82dfe447fb355c1521f475e1712c005d7d619fa
EBUILD click-help-colors-0.9.3.ebuild 698 BLAKE2B bea683889720ada08c37d50137118628d7268b3d6512f1c170904fb983b0733ac433e18b54e2e559ee4300da56190b67255e13be235e16f034ec9e4120179a0c SHA512 0355e3376ee90b2af16686b4e357a03b908e0c71c603f02c7118989e021d2f0bd4ed7279e966c0e8805cb7f2e514ff7b93742f9e0156ed6a083f59a6506c6f5b
+EBUILD click-help-colors-0.9.4.ebuild 698 BLAKE2B bea683889720ada08c37d50137118628d7268b3d6512f1c170904fb983b0733ac433e18b54e2e559ee4300da56190b67255e13be235e16f034ec9e4120179a0c SHA512 0355e3376ee90b2af16686b4e357a03b908e0c71c603f02c7118989e021d2f0bd4ed7279e966c0e8805cb7f2e514ff7b93742f9e0156ed6a083f59a6506c6f5b
MISC metadata.xml 522 BLAKE2B c281d2270d2e8389fcf83ece941af24a414107601d4c840731fbe952d73d71c32fd26276af21fa5ba4b2bdec0f35ef77a94a12a3239c1f053f50c9aff3e90d7e SHA512 45b82c348eea430dda7453b265e152f1d60d7a3aa17365b8d86ad57d17943ad7d44d5029504636e56c0b437a32e12f6e9c446d5fc6bb70fa72c72108b538f143
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
new file mode 100644
index 000000000000..1f2d4a2665be
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="
+ https://github.com/click-contrib/click-help-colors/
+ https://pypi.org/project/click-help-colors/
+"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}