summaryrefslogtreecommitdiff
path: root/dev-python/click-help-colors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/click-help-colors
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/click-help-colors')
-rw-r--r--dev-python/click-help-colors/Manifest2
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.1.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
index 199ecceff4b9..dda09a8df562 100644
--- a/dev-python/click-help-colors/Manifest
+++ b/dev-python/click-help-colors/Manifest
@@ -1,3 +1,5 @@
+DIST click-help-colors-0.9.1.tar.gz 101042 BLAKE2B 0f40d6d15f8e0a4647212f57e071c49b66bcd2b3d7ef582bd7d8a14135e50028f3ceb07987b5b74a868d998c12886a711f40e1d85b541566c63dca39e43a907d SHA512 ac4ce56ab249f7b98f670a6624700109f20a7c666e006b891d5c9fd4977512a0c94d82f6b43915952179abc946899f85fa1d358cd3d59508ef341ba22d8fc745
DIST click-help-colors-0.9.tar.gz 100701 BLAKE2B 838507658aec9cea962d1f373bd771871837d1fe274c70fe4555efbd4e1825203d8728457c5836a482add26e86d4eed83b962811602864d43bf8174f49bd89cd SHA512 02cca02a5cec6b3b23fdeee4aef921cac1cf83d85bea8eb04dd100955dc27b2e4d098bad2f49694c0aa6548135fb979a1fd054525dcec27077f461a034d62a87
+EBUILD click-help-colors-0.9.1.ebuild 602 BLAKE2B 20b54e68755c6201107ecce9f1b1515cd845ea534bc665b9099dfb7a5901f8102bafcbac37d46278c19d519cf54e3ef4825e92023cdccf9a6469d1311be3cdf0 SHA512 88dfb13846fa12889862e55f927d9fba42b2bb9a9e0a85c59bb416cdd737457922d7233b07e008a3dfa4ad19d16675f09783aa63f5b6fe8fac37c3f225738329
EBUILD click-help-colors-0.9.ebuild 612 BLAKE2B 093296e1bc0a492edcc6d6c29c1635d63352f2903f48103d1c0012daf5fe6429f7e5612da687810d4ae890542b3c260d9e431908522ffaa6d7859c5069d8e3ac SHA512 49175a08eda7d01d1f6211ac6021862a8b1f9e716b9d2e972530dadecdb225c32fb191906e55e8ea8b952c5392db28904ee40eb4b68ab13ff6778f2d8d422ebd
MISC metadata.xml 420 BLAKE2B b7f9eb67dcb6e7e6f2de54e0f8d96974147d92a5839fffb5d68201dcaad1ff600caae1971d9d0608366fafebaa270d8aa750bee3e51fa3a97ca12c2fdf6842dc SHA512 b1fce393231a5053ff90f5163e2a4788500f0819a0623f2b8a0df391ce37f085d11ae69d7db41235195a31bc83c6ff729058d6ac0aa66d155a1a652f485d65be
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
new file mode 100644
index 000000000000..251b5c3328a4
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="https://github.com/click-contrib/click-help-colors"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}