summaryrefslogtreecommitdiff
path: root/dev-python/cleo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-05 02:07:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-05 02:07:17 +0000
commita6764d56b1c85c8272783500983011c143c72d80 (patch)
tree4012d67c099814931c6188b22a6b5eb4e77f1d6a /dev-python/cleo
parent38ecaf88ae0891dd2d7f2bdd9a7acdcd45835724 (diff)
gentoo auto-resync : 05:12:2024 - 02:07:17
Diffstat (limited to 'dev-python/cleo')
-rw-r--r--dev-python/cleo/Manifest2
-rw-r--r--dev-python/cleo/cleo-2.2.1.ebuild53
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/cleo/Manifest b/dev-python/cleo/Manifest
index 5268964b9a50..17861920bf48 100644
--- a/dev-python/cleo/Manifest
+++ b/dev-python/cleo/Manifest
@@ -1,5 +1,3 @@
DIST cleo-2.1.0.gh.tar.gz 165795 BLAKE2B 7c9d0cc869d1e185c2c5a092a8aa1d1b3cce5fc25246939c0ff94920ac7070000b110be9f6cd9d1f827ed951ff22b9ad62e3c17a941022967b7599e456cda837 SHA512 e73a4c02470052f0f602fae8b5bf7073f3342d0816074398b19f0fb25caddda51b6d2fcb9ef57026638d0dc8861a2b5142d87551b105cefa5e54426e4aa1225c
-DIST cleo-2.2.1.gh.tar.gz 162526 BLAKE2B 2f5da066672ecf7067801cd6287cd81055be893001a00067ada150c76363dde1ad3dc715d030963a15cee56080a15d1843d34499a92a55a4d4a3dfe340239ce5 SHA512 905411ca3f4769b12857df807e19f42f88f2aade3dd9b7f38dc3e61efce926479a6afcfc4cfff622ec98122d35871eef47e9146a61a159d4cf083e9eceb3b4ed
EBUILD cleo-2.1.0.ebuild 1169 BLAKE2B 0fdb4e7545f76589748ad0281909cd1726a2cb13042611101f9713e6d7f01d24e55ff7dfbe13a2a648b76899965e2ea30475bd2f3321c0e2d87741fa055230b2 SHA512 72615fd98ba2333ff077d3078585be37ae21238107546d3f321b0582a9d47112ccb06a7acc5c39350391b30eafbfb35a02292c9f073bf395f5be7be89f1000b3
-EBUILD cleo-2.2.1.ebuild 1082 BLAKE2B 854df08c9b92a3d5742d72480c68279f9d1b84691b1fe49e5c7aa0ebf676e045ee2921a40a7c2ef7d2a6ec1e9ade3ed98360b481c86ffdd05ce557e2125483b2 SHA512 c88a44c4e5b72d2ac4d62aae8d674254ba2c372fca6267a6373cee4e96d8a70ca03307201356477b48d79636b81d55c9f46c677e68d20c4699c34f97013df6ae
MISC metadata.xml 403 BLAKE2B 0c5320880b1df824eac22cfc315a1dd2e910e581edc90eeecc25ad410b7e6bd458c1bf03af118d3eb7c82d1e10db7c6cea70080c1ced0d48f3f58cb69d47f8a7 SHA512 6bedf64675cdf2ff12f0f7369c90ab0d702b621dc6b370461e059b41337712f438d70faeb5cd86c5368bdedc73bf19af823f145e04b3983a44e952579300e3b5
diff --git a/dev-python/cleo/cleo-2.2.1.ebuild b/dev-python/cleo/cleo-2.2.1.ebuild
deleted file mode 100644
index 4bc240fc5885..000000000000
--- a/dev-python/cleo/cleo-2.2.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python tool for building testable command-line interfaces"
-HOMEPAGE="
- https://github.com/python-poetry/cleo/
- https://pypi.org/project/cleo/
-"
-SRC_URI="
- https://github.com/python-poetry/cleo/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin rapidfuzz
- sed -i -e '/rapidfuzz/s:\^:>=:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- tests/ui/test_exception_trace.py::test_render_debug_better_error_message_recursion_error
- )
- ;;
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock
- epytest
-}