summaryrefslogtreecommitdiff
path: root/dev-python/clang-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /dev-python/clang-python
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-6.0.9999.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index 46bfda0a9456..7afeb777d7fe 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -4,5 +4,6 @@ DIST cfe-5.0.1.src.tar.xz 11483036 BLAKE2B c4eb54cd8271b62cf7a2219db0b599b68c00b
EBUILD clang-python-4.0.1.ebuild 864 BLAKE2B 40d3452c9f28d5c154a51258a764bc380addf20f8fb71e8f5e3d9a0fb60822d805df009f58f24457b834870a07abe365bcb6d3ed6557713282129992c1ae1d84 SHA512 d2900dfa55a69965e146800f097f8be256d022aca8d85f54db205f75b30cf72015d27c4e8f4981725d50c7a1c2a14c15454f009b2d8a3636103d6d133b0a2324
EBUILD clang-python-5.0.0.ebuild 1042 BLAKE2B 088a4a42d710bd352214cc9d214955c8fba03adcdaefe139650cecd98152e1811b9370ce96a1add8157c3a51cc7ea3556d7783367a4c5929c3b9bfff53992fee SHA512 bde63d6e9c8abb61fd9f2cf5382cdec7eb28529169e3153e8a4611c4af59ea2fae148a872ee090131816276c4bbd139f018e10d0431408ca7f335707ca7c2d53
EBUILD clang-python-5.0.1.ebuild 1018 BLAKE2B 84acc3e37c530b17f6d4b21bd6ef519cb8cf960efaab0d3241736f3bc6d8c28d0e5764e76b2d7e4becd024b3ae6662c3fa125e0a2baa9a28c05b157460839e22 SHA512 adc39f63cb3b8edebd2344e35b325cc006b29f524d7e20b2cc6a44476595bc873733bc776fab50584c1b30700e2a51cbeaed13531b6032e5ff244d856a06f1ba
+EBUILD clang-python-6.0.9999.ebuild 988 BLAKE2B f83893a8d12607cac36cb8963205d7104864e4b7e644856c619d483739b530e00ac1b4de96bcf6cb312180a2e7bb47f7a0c8dcae32bb06e8ca5e55a53927fdff SHA512 eff745749f8a606b584f359ed6f68b2dd18f2192b1bc6ea0e6337dea6f35240c8f9ea2304039a638c549bf60c28470134e0fa580b3daeaee592bfc13ff3e2ed7
EBUILD clang-python-9999.ebuild 963 BLAKE2B 1a6d55304c90f7e01c10321401490bcc88be4672d1c28e1eb1759ba42179a495b7d5a46b552af46ed310e20df48df4746b89e9b8e64269846f7131775f4c61f0 SHA512 d1e933646aa6069c5140b490c7070ddc2d41698b92052793d51339dfd622ed2e7624bd23bffded5d6cd9d72a329eaa1e3318618a55cb557c53cbe511c409e685
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/dev-python/clang-python/clang-python-6.0.9999.ebuild b/dev-python/clang-python/clang-python-6.0.9999.ebuild
new file mode 100644
index 000000000000..e0aa3318ebd9
--- /dev/null
+++ b/dev-python/clang-python/clang-python-6.0.9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit git-r3 python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/bindings/python
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' bindings/python
+}
+
+src_test() {
+ python_foreach_impl python -m unittest discover -v || die
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}