summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-5.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
commitd00821e77f72d4af4ea30158c1c6e18ffff0875b (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /dev-python/clang-python/clang-python-5.0.2.ebuild
parent36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (diff)
parent6a339b4f9ec107438bb71a6f9ca72fd42fbfd436 (diff)
Merge branch 'next'
Diffstat (limited to 'dev-python/clang-python/clang-python-5.0.2.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-5.0.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/clang-python/clang-python-5.0.2.ebuild b/dev-python/clang-python/clang-python-5.0.2.ebuild
deleted file mode 100644
index c7b8804e71fb..000000000000
--- a/dev-python/clang-python/clang-python-5.0.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit python-r1
-
-MY_P=cfe-${PV/_/}.src
-DESCRIPTION="Python bindings for sys-devel/clang"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# The module is opening libclang.so directly, and doing some blasphemy
-# on top of it.
-RDEPEND="
- >=sys-devel/clang-${PV}:*
- !sys-devel/llvm:0[clang(-),python(-)]
- !sys-devel/clang:0[python(-)]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}/bindings/python
-
-src_unpack() {
- einfo "Unpacking parts of ${MY_P}.tar.xz ..."
- tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
-}
-
-python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- python_foreach_impl python_test
-}
-
-src_install() {
- python_foreach_impl python_domodule clang
-}