summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/clang-python/clang-python-10.0.1.9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/clang-python/clang-python-10.0.1.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-10.0.1.9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.1.9999.ebuild b/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
index fc791c8175c3..e1b9340c6319 100644
--- a/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
+++ b/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit llvm.org python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
@@ -27,6 +27,11 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
+src_prepare() {
+ cd "${WORKDIR}" || die
+ default
+}
+
python_test() {
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}