summaryrefslogtreecommitdiff
path: root/dev-python/chump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/chump
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/chump')
-rw-r--r--dev-python/chump/Manifest5
-rw-r--r--dev-python/chump/chump-1.5.1.ebuild18
-rw-r--r--dev-python/chump/chump-1.5.2.ebuild41
-rw-r--r--dev-python/chump/metadata.xml14
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/chump/Manifest b/dev-python/chump/Manifest
new file mode 100644
index 000000000000..e6f3af3876c4
--- /dev/null
+++ b/dev-python/chump/Manifest
@@ -0,0 +1,5 @@
+DIST chump-1.5.1.tar.gz 9370 BLAKE2B 28c7280aa0fa3fb81a4981ea3892533eb0af6f1655c41bdf8f250ea78806eac7b3d5f21143af83f22b8063913185e77774eb7be2b8ff2bbe5371c690f726acb5 SHA512 778e043e4641b433a03860f1b1b144cdd34d0f79fb20ec0801cea1e1473eade8dd5211ffca391a57eb1f01456ec33cef4db6359839e7e39eab169411d00471e3
+DIST chump-1.5.2.tar.gz 12920 BLAKE2B 5fde4774009ebda37e7a9f9c9cfedea3d4e19a9be1aeb165dd867a8ec8cc69385855c22763bc822d3a65d76c70cfe7ef41e4761319dbfaca9587301570765a8d SHA512 6b836bac1ab38c88084f9d6608a9ed88b305847faabcf5de6c13d587e91dc92b21334877cb9290dd56873de40be92f31f2bab3a345c7a7e62259004f5762cda4
+EBUILD chump-1.5.1.ebuild 419 BLAKE2B 4584adc7eff2f07e83815579dab491a2ea8ae7749d7631a1275f3092eeaae19f173cd36cd3923c8ce66167825846c00e736f3ad3962acc84c2c9805d98aacedf SHA512 8baaa8979f9a129254de02747d06f8300def23aefdeccb1a3c10c68eec07f996ccef683aeeb1ec5006c4b5704208b519dbff4f430430018d07dc322f875f96da
+EBUILD chump-1.5.2.ebuild 1078 BLAKE2B 383c5d6dddfa8b4c57fb444fba3c67dc0deb11da45b1a3f9ae93908a5cf096d0282c5e917dd0363a756a3d1d26eb837fe06a161b02f98c2b848f830425c75426 SHA512 4f252f7e6f749c3f15d91cf34f10a9ebc7119fe32461cca2d6c27cc34dbd5bb8d32ad094c78e47982fa46088b6b3418a0c8adf05b4ac2f69caa67b52c7190389
+MISC metadata.xml 518 BLAKE2B 126300d60995a32912c84d734b465bdc4ad7f4569aeeae7674325dbd44c177431dffb22e05341cc50e8ac0f294617c64c18c11e3b5f7bfb17eb083f48f06ffdc SHA512 bf56b4200d946208832b539649d18f450da83e2bcc31bff902ad8793fb27f823e2e4207175cc13db3ae49f1862b5889a36fa06d27ec412da647cbdb2c4286604
diff --git a/dev-python/chump/chump-1.5.1.ebuild b/dev-python/chump/chump-1.5.1.ebuild
new file mode 100644
index 000000000000..d30f5ec3555d
--- /dev/null
+++ b/dev-python/chump/chump-1.5.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/chump/chump-1.5.2.ebuild b/dev-python/chump/chump-1.5.2.ebuild
new file mode 100644
index 000000000000..3e5449f598e0
--- /dev/null
+++ b/dev-python/chump/chump-1.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+# PyPI tarballs currently don't contain docs
+# https://github.com/karanlyons/chump/pull/10
+# Releases are not tagged on GitHub
+# https://github.com/karanlyons/chump/issues/9
+SRC_URI="https://github.com/karanlyons/${PN}/archive/0cd59e14267858ab6623d7aa42badc6caa9b8edf.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Force sphinx to use the standard theme
+ use doc && READTHEDOCS=True emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chump/metadata.xml b/dev-python/chump/metadata.xml
new file mode 100644
index 000000000000..39730ef9f1da
--- /dev/null
+++ b/dev-python/chump/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">chump</remote-id>
+ <remote-id type="github">karanlyons/chump</remote-id>
+ <bugs-to>https://github.com/karanlyons/chump/issues</bugs-to>
+ <changelog>https://github.com/karanlyons/chump/blob/master/HISTORY.rst</changelog>
+ </upstream>
+</pkgmetadata>