summaryrefslogtreecommitdiff
path: root/dev-python/chump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/chump
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/chump')
-rw-r--r--dev-python/chump/Manifest6
-rw-r--r--dev-python/chump/chump-1.5.1.ebuild18
-rw-r--r--dev-python/chump/chump-1.5.2.ebuild41
-rw-r--r--dev-python/chump/metadata.xml18
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/chump/Manifest b/dev-python/chump/Manifest
new file mode 100644
index 000000000000..16f3a29e0ce3
--- /dev/null
+++ b/dev-python/chump/Manifest
@@ -0,0 +1,6 @@
+DIST chump-1.5.1.tar.gz 9370 SHA256 5aa5a1a4a0c0baa610e742018f5cce508fa4c980b15188664de0d3834e76b857 SHA512 778e043e4641b433a03860f1b1b144cdd34d0f79fb20ec0801cea1e1473eade8dd5211ffca391a57eb1f01456ec33cef4db6359839e7e39eab169411d00471e3 WHIRLPOOL dd78cd570060e75ab74e9e42e311dc3b0f096cc0fec588ad6c8378be314ec675b1557f172db945091d09caf10e26b04ec1ff92ffeb30a32df8254b2048728089
+DIST chump-1.5.2.tar.gz 12920 SHA256 e2274993917373dc2a25c52fb4c23d26e11d11c987d882ece8683d4f55eb64d3 SHA512 6b836bac1ab38c88084f9d6608a9ed88b305847faabcf5de6c13d587e91dc92b21334877cb9290dd56873de40be92f31f2bab3a345c7a7e62259004f5762cda4 WHIRLPOOL 442bd78fb5ad9f506ef903f1193ae98a66c29a5a10321512a40c64cca326b324ec8717538f0ba5542d26f4523badd5d4f0dd0b99e123918c6862d4214fd5be63
+EBUILD chump-1.5.1.ebuild 419 SHA256 23b0db36d9b1c885dbd2db0836e3f3d83863cdccbedb8ea7c7b49563751ced6e SHA512 8baaa8979f9a129254de02747d06f8300def23aefdeccb1a3c10c68eec07f996ccef683aeeb1ec5006c4b5704208b519dbff4f430430018d07dc322f875f96da WHIRLPOOL d401ba568a593ade447f2f3150ded83163613279341b4392dd98e51722b2f32f1d7d9af0dd2d9e8a42b0d99ad5229c6c47659595294ac4507ec61d7deccec61a
+EBUILD chump-1.5.2.ebuild 1074 SHA256 113756bc7709c211784988629587946e5d71180d9185aebafafab60015b6fe4e SHA512 70e318e19a6586333dc3abf574ed9f71d377e32ca9dd58e9d1794429793501cff55b0095b78898c1ac9c0a71d0a7c853c919e0afd86e44e7891215bbea8bdf9c WHIRLPOOL 77a5dcaea68939225b5b51a44e94e7db2cd03d6a23c55d05db25d90ba8b19051c3f6d72d7c7ff6491956e82ab0c36d5d3e00a4648be035b05b0931e344bd37b4
+MISC ChangeLog 683 SHA256 80c7288fa8bb36021ccac4a3c9e3c409196f150357d528a7df185b01213bab4c SHA512 d4d54331e7c4b266d88d67e667384b39530ce3225db84259e9d167517cd3afdc17adfd8e7cabc6a70d20068aed20f7fd76be31bf67593604f7b9c34cb0a2e4d4 WHIRLPOOL 26881a56825005cc61f275a346a8a0debab7262aae0c49662fdcf38af415a189b2cdcb8e165381bd8d3a3847bda4464c9c33ef7cb95d17426ad1bc4d4cd8c25f
+MISC metadata.xml 642 SHA256 59759c0f4b69cb520d29d49813d59339bb6caa9816321559bba6c174972d4f31 SHA512 905df2be7eb01ea16546f358169faed780f33e8f65d7b3266527b43ed46ff8bf49e25040206db62c5ede545e74bc947f588a3bb94a31c92dbd8f9e7cebf4d704 WHIRLPOOL 273ccb63f6eb313dc876966476189ce430c36d39f57ca73b0de86514e464998cdbe760cab59ad3c4f90fdb34066653114cba73fc8abba4ea4e1593e85cf7a057
diff --git a/dev-python/chump/chump-1.5.1.ebuild b/dev-python/chump/chump-1.5.1.ebuild
new file mode 100644
index 000000000000..d30f5ec3555d
--- /dev/null
+++ b/dev-python/chump/chump-1.5.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/chump/chump-1.5.2.ebuild b/dev-python/chump/chump-1.5.2.ebuild
new file mode 100644
index 000000000000..e799f566f49c
--- /dev/null
+++ b/dev-python/chump/chump-1.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+# PyPI tarballs currently don't contain docs
+# https://github.com/karanlyons/chump/pull/10
+# Releases are not tagged on GitHub
+# https://github.com/karanlyons/chump/issues/9
+SRC_URI="https://github.com/karanlyons/${PN}/archive/0cd59e14267858ab6623d7aa42badc6caa9b8edf.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Force sphinx to use the standard theme
+ use doc && READTHEDOCS=True emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chump/metadata.xml b/dev-python/chump/metadata.xml
new file mode 100644
index 000000000000..577981393aed
--- /dev/null
+++ b/dev-python/chump/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">chump</remote-id>
+ <remote-id type="github">karanlyons/chump</remote-id>
+ <bugs-to>https://github.com/karanlyons/chump/issues</bugs-to>
+ <changelog>https://github.com/karanlyons/chump/blob/master/HISTORY.rst</changelog>
+ </upstream>
+</pkgmetadata>