summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-01 02:06:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-01 02:06:43 +0000
commitc635a4b7ddb6105bfc6fef130b188a087726677b (patch)
tree6707959596af4883f9621a0cdf56d35c06dbc63e /dev-python/cherrypy
parent080d89feff80cae2fc974ff2f24d463141c20635 (diff)
gentoo auto-resync : 01:12:2024 - 02:06:42
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest2
-rw-r--r--dev-python/cherrypy/cherrypy-18.10.0.ebuild28
2 files changed, 21 insertions, 9 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index 06ab6a24193b..79a722812635 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,3 +1,3 @@
DIST cherrypy-18.10.0.tar.gz 633708 BLAKE2B b403ac983da855c7bf44b6909cc984a544d61cfa3191fae81f15b01d6b2d5d5e4bcd8c9f99c550e39540aac75d14523724602ddf121768c43bcbb93235e0941b SHA512 6c77d89e484fc1cf5a8e7523d1ebb04ba49930823905142ab016aabc80924e1173c97342f172585758c28faee1b329e26fe04dd1e36c559b7798495d45fdc36f
-EBUILD cherrypy-18.10.0.ebuild 1718 BLAKE2B 0155d46b137c8121b524390cfb3328c5158ef2aebe790aa98f973bf113ba40cab8273ee46d599b9bdae03f7c33881251400379176f2ba517e1918dc9722eccc6 SHA512 bad4ccf1a04d5cb04d4e2ca74862baf5136f142c16320c81d2570da17b06b8735c1f5494bc7014320b65a5af42c13077d4ad297c6a4f2a193ffb7a84a42253de
+EBUILD cherrypy-18.10.0.ebuild 1993 BLAKE2B baeb47c7980f1e482371a8b7c6f54d29b1a7160c3b5f06a3bee4e8c172f64c40d4384b89b41a799a39fc4530d010f5ad8f1e2fc5fa40fa5415b620d373363db5 SHA512 08239ffd2bd7fcea09318cdaef570464cbed8d709e8d8d87010f7444f037d6876b08c20516b8ecd77e27d3fe666fdbb3c58dd716a3fbbc0f9971dfc1124511df
MISC metadata.xml 469 BLAKE2B 8a5e41d7cee996975da9df7a30172bfebd1b715581bc5e4de1934a97332af16a18c928b33ad088723618f3dd694101639702c5d6c2619e3db46c488992aa67a3 SHA512 d08a8114dcdefa5e27a2382604953c7635d376f941f92a128e229f42c3b236da0e36287182c2be735b624566a6bb5dd1c3541bf67396e33169f86e6dd0d0c09a
diff --git a/dev-python/cherrypy/cherrypy-18.10.0.ebuild b/dev-python/cherrypy/cherrypy-18.10.0.ebuild
index 4b09ba655dcf..ae0a09d7de53 100644
--- a/dev-python/cherrypy/cherrypy-18.10.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-18.10.0.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ppc ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="ssl test"
RDEPEND="
@@ -39,7 +39,11 @@ BDEPEND="
dev-python/objgraph[${PYTHON_USEDEP}]
dev-python/path[${PYTHON_USEDEP}]
dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/pytest-services[${PYTHON_USEDEP}]
+ !sparc? (
+ net-misc/memcached
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-services[${PYTHON_USEDEP}]
+ )
)
"
@@ -56,11 +60,19 @@ python_prepare_all() {
python_test() {
local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # broken by changes in traceback output
- cherrypy/test/test_request_obj.py::RequestObjectTests::testErrorHandling
- cherrypy/test/test_tools.py::ToolTests::testHookErrors
- )
+ local opts=()
+
+ # These tests are gracefully skipped when pylibmc is missing but not
+ # if pytest-services is missing -- even though that's the only test
+ # using these fixtures.
+ if ! has_version "dev-python/pytest-services[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ cherrypy/test/test_session.py::MemcachedSessionTest
+ )
+ else
+ opts+=( -p pytest-services )
+ fi
- epytest
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest "${opts[@]}"
}