summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/cherrypy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest5
-rw-r--r--dev-python/cherrypy/cherrypy-13.1.0.ebuild43
-rw-r--r--dev-python/cherrypy/cherrypy-3.8.0.ebuild51
-rw-r--r--dev-python/cherrypy/metadata.xml11
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
new file mode 100644
index 000000000000..adcbb396662d
--- /dev/null
+++ b/dev-python/cherrypy/Manifest
@@ -0,0 +1,5 @@
+DIST CherryPy-13.1.0.tar.gz 687221 BLAKE2B ab9c8f50026e26d171877e4e68f1c5a53fa8519190bcc577e12999cdf8a7f52be37f4ba9ed83a276a9f33676839ec63bff68aa8f9f51ddf15557e09123bf2530 SHA512 c32cf009d6a5b557560a00cde0f47a01ae481c7f60b7f340e5c99bf2d7c757e7c7cbf3ef2f4f71c172057aa09ca332f2d211cc97623ea29ba9f17287c7bc42dd
+DIST CherryPy-3.8.0.tar.gz 433711 BLAKE2B e1b4a554138a61e8c6313c3055723583d812e573a352d67bd5448f799e4f2f22694b800810b53cd041c665e46d9555b471d1da91c252ade96459778d7a5c07fa SHA512 25f84093e30d814c0980f7d77b98492113470c3297c66ee8652e40650757f8e2b7db01bb8de6d7a1ea9b4bed8b764502b1f563ac6f0d082970bc2d46739d19c2
+EBUILD cherrypy-13.1.0.ebuild 1315 BLAKE2B cda7c4bb1e448d6c3b90f29fdc2b922948f11f95093802a619c7cefa4c2801cbee43c68d84cad05b12df58595980c8ee577828215cc782259ba617f74822886c SHA512 838c526451084177255f3aebc423de00a97daa670b88ab3dc6e69441d05be5757f1211d02a3dbf7c312ddb250815e2fdd9d7f991120b96eba3852d492bf08a7a
+EBUILD cherrypy-3.8.0.ebuild 1658 BLAKE2B 089308d96b63adf0e0563f0d4648290ab16998b0359c6802c803f85e147e604aebbe379884eebfec859035d54a96df57ff96967f73ad41929eb6088373237898 SHA512 04ab8e0a5b192bb61f926e9a0eb1bf1f52444f4899b963c21b6557abd79740766ff60510bc51292e614700893298d7989eb3e05fe85377a090d3651ffa04e3d7
+MISC metadata.xml 321 BLAKE2B 6636b11693e6e9d09f579bc88b203bd7c41f67222887365de5db2c3aca4c34d8cb2e341f217240ce562f43d60e78221442c12b08f2f7e516c36e06d928a9a995 SHA512 c777da5d545e3d626d663830437ec91a8f228c58734c7df4e4a16f0609904a5ad4613310d2d05b4e8ea89053371ad0bd4f0624137afe54ff6c4f5d9eef734d10
diff --git a/dev-python/cherrypy/cherrypy-13.1.0.ebuild b/dev-python/cherrypy/cherrypy-13.1.0.ebuild
new file mode 100644
index 000000000000..7b4c9303a2eb
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-13.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
+ >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
+ sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
+ -i cherrypy/test/test_static.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}
diff --git a/dev-python/cherrypy/cherrypy-3.8.0.ebuild b/dev-python/cherrypy/cherrypy-3.8.0.ebuild
new file mode 100644
index 000000000000..c5d07f118d9d
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.3.3[${PYTHON_USEDEP}] )"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+# testsuite predominantly connects to the network
+RESTRICT="test"
+
+python_prepare_all() {
+ # Prevent interactive failures (hangs) in the test suite
+ sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # suite requires current latest nose-1.3.3
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1308
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1306
+ local exclude=(
+ -e test_file_stream -e test_4_File_deletion -e test_3_Redirect
+ -e test_2_File_Concurrency -e test_0_Session -e testStatic
+ )
+
+ # This really doesn't sit well with multiprocessing
+ # The issue 1306 tells us some tests are subject to the deleterious effects of
+ # the 'race condition'. Both the issues are unresolved / open
+# if [[ "${EPYTHON}" == pypy ]]; then
+ nosetests "${exclude[@]}" -I test_logging.py || die "Testing failed with ${EPYTHON}"
+# else
+# nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
+# fi
+}
diff --git a/dev-python/cherrypy/metadata.xml b/dev-python/cherrypy/metadata.xml
new file mode 100644
index 000000000000..b1a626fc10bf
--- /dev/null
+++ b/dev-python/cherrypy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">CherryPy</remote-id>
+ </upstream>
+</pkgmetadata>