summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/cherrypy
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest1
-rw-r--r--dev-python/cherrypy/cherrypy-13.1.0-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index adcbb396662d..c0c76caae4ab 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,5 +1,6 @@
DIST CherryPy-13.1.0.tar.gz 687221 BLAKE2B ab9c8f50026e26d171877e4e68f1c5a53fa8519190bcc577e12999cdf8a7f52be37f4ba9ed83a276a9f33676839ec63bff68aa8f9f51ddf15557e09123bf2530 SHA512 c32cf009d6a5b557560a00cde0f47a01ae481c7f60b7f340e5c99bf2d7c757e7c7cbf3ef2f4f71c172057aa09ca332f2d211cc97623ea29ba9f17287c7bc42dd
DIST CherryPy-3.8.0.tar.gz 433711 BLAKE2B e1b4a554138a61e8c6313c3055723583d812e573a352d67bd5448f799e4f2f22694b800810b53cd041c665e46d9555b471d1da91c252ade96459778d7a5c07fa SHA512 25f84093e30d814c0980f7d77b98492113470c3297c66ee8652e40650757f8e2b7db01bb8de6d7a1ea9b4bed8b764502b1f563ac6f0d082970bc2d46739d19c2
+EBUILD cherrypy-13.1.0-r1.ebuild 1310 BLAKE2B 1619274c955202e6c22dbba3cbaf3bdd6c3736063b9e4659b393906d24debbbdebf548b9592c719b46c70392f09694a7b0dd4a09b0bacf3b87cdf40966e933c8 SHA512 939e7f71d2cbbd383d0cdcdee07f3fbf1ac8a4c5197985cc4bb5c80cfd7e999cad28682146e1a0ceb858fab1f7188585603521fe7e9d9e9436ff85bfd0b3d029
EBUILD cherrypy-13.1.0.ebuild 1315 BLAKE2B cda7c4bb1e448d6c3b90f29fdc2b922948f11f95093802a619c7cefa4c2801cbee43c68d84cad05b12df58595980c8ee577828215cc782259ba617f74822886c SHA512 838c526451084177255f3aebc423de00a97daa670b88ab3dc6e69441d05be5757f1211d02a3dbf7c312ddb250815e2fdd9d7f991120b96eba3852d492bf08a7a
EBUILD cherrypy-3.8.0.ebuild 1658 BLAKE2B 089308d96b63adf0e0563f0d4648290ab16998b0359c6802c803f85e147e604aebbe379884eebfec859035d54a96df57ff96967f73ad41929eb6088373237898 SHA512 04ab8e0a5b192bb61f926e9a0eb1bf1f52444f4899b963c21b6557abd79740766ff60510bc51292e614700893298d7989eb3e05fe85377a090d3651ffa04e3d7
MISC metadata.xml 321 BLAKE2B 6636b11693e6e9d09f579bc88b203bd7c41f67222887365de5db2c3aca4c34d8cb2e341f217240ce562f43d60e78221442c12b08f2f7e516c36e06d928a9a995 SHA512 c777da5d545e3d626d663830437ec91a8f228c58734c7df4e4a16f0609904a5ad4613310d2d05b4e8ea89053371ad0bd4f0624137afe54ff6c4f5d9eef734d10
diff --git a/dev-python/cherrypy/cherrypy-13.1.0-r1.ebuild b/dev-python/cherrypy/cherrypy-13.1.0-r1.ebuild
new file mode 100644
index 000000000000..e83a1a913f65
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-13.1.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
+ >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
+ sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
+ -i cherrypy/test/test_static.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}