summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
commit06dcf64674a43718324bffee383625d2cd050b75 (patch)
tree4de58e857f3f0718fef4fc386e42577c2f4c9478 /dev-python/cherrypy
parent198bd0cd3c1be97f7deb5283fa00048718482de4 (diff)
gentoo auto-resync : 07:11:2023 - 22:21:54
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest5
-rw-r--r--dev-python/cherrypy/cherrypy-18.8.0.ebuild7
-rw-r--r--dev-python/cherrypy/files/cherrypy-18.8.0-py312.patch30
-rw-r--r--dev-python/cherrypy/metadata.xml1
4 files changed, 40 insertions, 3 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index dd16302f6da3..3d2e478895a5 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,3 +1,4 @@
+AUX cherrypy-18.8.0-py312.patch 1167 BLAKE2B 0c994cebfefa44fe0ea13210046f391c911db0633adbf1db70013421b4219f63b4986cc3a18fbfbc708fc806fdab5c78b51036dd6c5a4863cf249071b8df2f05 SHA512 06d647b824de4b1fef2a596f323944440f6dd1ef0cdf0fa088db3544f45a63deb9980b2d3588309f06ad6ff97742588be5363c29adbf0b69766760c67ecee179
DIST CherryPy-18.8.0.tar.gz 622679 BLAKE2B 673f9a103a901161ee801656fa37fa0a4fcd2d9276a5231e48c1663264eb7f922d5d862018995a345a8485252416fa0229da49b8d265288efce2dccd37d79ff8 SHA512 abacc995c1757b8d0171d57eb59b6e5931c46019d8f0f43479e334bb4f58b61a27541d9d0997d665f81905bc3c89e42d40d8e5a6e3a5f9bf251bc9089ceb5249
-EBUILD cherrypy-18.8.0.ebuild 1731 BLAKE2B c2d2b9ffefe018d9b3a06f63a6644c30589e2ffd905f2d5c98cd286e397ba9bb9eff71d8296e6787683ea215a19cb2c7c88e49b648ea3cc981bf934ee486a3f8 SHA512 905bb819dc4dbb17132173a0d6b3be0fe6eb44707154cb7313af5614173220a4b1685f7db620eb2d0229bfae9486ee01bf811175a7a04b4aadb95eb583258495
-MISC metadata.xml 347 BLAKE2B 7694118d09caebdeac890ee40fd8a79906637bb695f9ec44dc25e67378c8c7f06901e5c52e6f79dd498921ffa01b18b9762b102baeea34792a2ff730a1303c40 SHA512 29cbadf45008c3c422c47ca232634bd15efbd4bcdc6065d18cf1adcbc0c3bbb155a2b122eb4ce7180839fcdaf4acb5515486f191ebbfa63eaec8a14abbb1e3eb
+EBUILD cherrypy-18.8.0.ebuild 1837 BLAKE2B a1ca1f5565c3a43fa180a8624bd42d4b7c256396c52b283fc8131f0d731bd0cfa044ca6c3c9f2808b75885b2b47ecf5ab2b527d84f78fad094ed338c74fc1c60 SHA512 d6f56161f87956325757dfece47d84b32b5c9582a4bad2dbc3a322d678c500de72b97c54a946f22d48a6ff07e750fe3a7567999c56c46bf2513176479df8a124
+MISC metadata.xml 406 BLAKE2B 8de723de4f5cd4adcfa9415a9fe29039fe2783ba00d78e6f9272a47f1fc3d76b788ac1b17c41f8946ec7a4b2956e4e392c3ea4468392f627e67c99cb5917ee56 SHA512 2910d80ba4c583b448fd29be7d59cfa01c0795a077f11ba96a4a912b78ca4529dbbb85baffb68b6d499927b94437a94fb61eab393f55fb253f5978c8b0b6535e
diff --git a/dev-python/cherrypy/cherrypy-18.8.0.ebuild b/dev-python/cherrypy/cherrypy-18.8.0.ebuild
index bc25b0613a09..f1daafcdd228 100644
--- a/dev-python/cherrypy/cherrypy-18.8.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-18.8.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN="CherryPy"
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -47,6 +47,11 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
+ local PATCHES=(
+ # https://github.com/cherrypy/cherrypy/pull/1959
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
sed -i -e '/cov/d' pytest.ini || die
# upstream has been using xfail to mark flaky tests, then added
# xfail_strict... not a good idea
diff --git a/dev-python/cherrypy/files/cherrypy-18.8.0-py312.patch b/dev-python/cherrypy/files/cherrypy-18.8.0-py312.patch
new file mode 100644
index 000000000000..90e63a763f99
--- /dev/null
+++ b/dev-python/cherrypy/files/cherrypy-18.8.0-py312.patch
@@ -0,0 +1,30 @@
+From d2bc527c12a74675d67ba5fbf9de0d014af929cb Mon Sep 17 00:00:00 2001
+From: Dan Radez <dradez@redhat.com>
+Date: Tue, 12 Apr 2022 09:40:46 -0400
+Subject: [PATCH] Replace readfp with read_file
+
+Getting Deprecation Warning in python 3.11:
+DeprecationWarning: This method will be removed in Python 3.12.
+Use 'parser.read_file()' instead.
+
+https://github.com/python/cpython/commit/e8659b47dece5a272111c0af5e340c364a9f807b#diff-ca80d44aeeadd5e4966195b99aff106abb3e7b0b5356b7499125ee021bd84777R757
+
+If I'm reading this correct read_file has been around since Python 2.7
+https://github.com/python/cpython/commit/a492362f9a2a44e411147fd7b2886466bb0bb17f
+---
+ cherrypy/lib/reprconf.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cherrypy/lib/reprconf.py b/cherrypy/lib/reprconf.py
+index 76381d7b7..536b94173 100644
+--- a/cherrypy/lib/reprconf.py
++++ b/cherrypy/lib/reprconf.py
+@@ -188,7 +188,7 @@ def as_dict(self, raw=False, vars=None):
+
+ def dict_from_file(self, file):
+ if hasattr(file, 'read'):
+- self.readfp(file)
++ self.read_file(file)
+ else:
+ self.read(file)
+ return self.as_dict()
diff --git a/dev-python/cherrypy/metadata.xml b/dev-python/cherrypy/metadata.xml
index 8903904e0b9a..d773247b15fb 100644
--- a/dev-python/cherrypy/metadata.xml
+++ b/dev-python/cherrypy/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">cherrypy/cherrypy</remote-id>
<remote-id type="pypi">CherryPy</remote-id>
</upstream>
</pkgmetadata>