summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-python/cheroot
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest3
-rw-r--r--dev-python/cheroot/cheroot-6.0.0.ebuild30
-rw-r--r--dev-python/cheroot/metadata.xml12
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
new file mode 100644
index 000000000000..7b0eb8afd19a
--- /dev/null
+++ b/dev-python/cheroot/Manifest
@@ -0,0 +1,3 @@
+DIST cheroot-6.0.0.tar.gz 62763 BLAKE2B 0946c01c6a6233dc60ca3dd896c3d1dbc0feb97d5099d88598db340a8812b2be4cb076383c0e39d30cd2c6fd3402e048b716a02e82bec8ce08d5b8fca4b1be0f SHA512 0109fbf3b73ed3f12261eaa3c6d86b6c6b80a1ba3564548ba3288aa6c61a1c08db60886e677991bf7997e6a5b1ec7767a3e06098ec1748453e72c40fda7b82a7
+EBUILD cheroot-6.0.0.ebuild 876 BLAKE2B eee4d4129b9bf98e636c51f60062fbeb654c04030a71f9b94fe42dbd47a1b478b2e9a09c9adbfc4eb44f35b1f8a3944bfa869642d09629a4b6bb6c7ee35242d8 SHA512 5f88e92244e47caeb22b6f0dd6d935650ec0afe1a88981f3d5e7df961fe09e36dffd9ed5c639317f19ecd72815a99e278df46291c9eb7dfc59b3c98a49df1d7b
+MISC metadata.xml 370 BLAKE2B df7ec3eb606f1557e048245eca81402f40f9cd9bc4ec8112ecb0085f65530d9a66b952d56f826b2b97733018ec4b4d31c16ac26bebd3a40f3424421255fcb770 SHA512 22ff00c4677bd898e9d88f2bdebabed6a145a9dd33d6276e997c0435c64fc9dfd396a35a88c6facc8a3844187f0b598bfe8606637ea88420a6c33e1ea9765cbf
diff --git a/dev-python/cheroot/cheroot-6.0.0.ebuild b/dev-python/cheroot/cheroot-6.0.0.ebuild
new file mode 100644
index 000000000000..5d94442756cd
--- /dev/null
+++ b/dev-python/cheroot/cheroot-6.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="http://www.cherrypy.org/ https://pypi.python.org/pypi/Cheroot https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}
diff --git a/dev-python/cheroot/metadata.xml b/dev-python/cheroot/metadata.xml
new file mode 100644
index 000000000000..c8449665a6e4
--- /dev/null
+++ b/dev-python/cheroot/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Cheroot</remote-id>
+ <remote-id type="github">cherrypy/cheroot</remote-id>
+ </upstream>
+</pkgmetadata>