summaryrefslogtreecommitdiff
path: root/dev-python/cheetah3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/cheetah3
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/cheetah3')
-rw-r--r--dev-python/cheetah3/Manifest4
-rw-r--r--dev-python/cheetah3/cheetah3-3.2.4.ebuild3
-rw-r--r--dev-python/cheetah3/cheetah3-3.2.6.ebuild41
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-python/cheetah3/Manifest b/dev-python/cheetah3/Manifest
index efaee741a92f..2f7c1d2e757a 100644
--- a/dev-python/cheetah3/Manifest
+++ b/dev-python/cheetah3/Manifest
@@ -1,3 +1,5 @@
DIST cheetah3-3.2.4.tar.gz 315044 BLAKE2B 5cb36364f424acf87593b3f18b5709d1a161dd3fb9bc1f4cfb6fe7c22d2515c852d5d7d0215692274ffe5437267e3232fcfae3d76c592cf66d8927fabdf37953 SHA512 64fbe95fe8d5f3185168ba780e106a46caa0656272235168df603eff50dd6e476eed041658a1e11ae12ee10d148a001c32a23677a1ee6da5b6d43e20e4d1e36e
-EBUILD cheetah3-3.2.4.ebuild 1111 BLAKE2B 929c5ce9da8a99bdc9ba0daf4dae1970e662b668c4d133449148b39abfb6ace991f2d30b8d4df09a6208258ac15eab8c991afd82ac15f5b6ee1e649dd773b7bb SHA512 077e5fc0a1fac2f669d6d87b5ca04d20f45ff5886e91d0b2a05860e5dcd9035541be3d4201b4b6d4b7ccd46ee300acf22c859e65a9502e03f9b608683c441f91
+DIST cheetah3-3.2.6.tar.gz 2481158 BLAKE2B cb8ad192ae9caf0d1284294b323cf4a918cd2fc951bae25867d69a3dd7933728056b76fbf52a22d34f290056a96cce7d9ccbeb2404f2f0bb782f8db8b7453e47 SHA512 abf74def695018a79cb1364f60e402e7e0095a4d2f069decfbddf42501d865b70451ebc7b52abc67aa23e57276d7a3b8c2894a9571876e15db43cd1358f74d31
+EBUILD cheetah3-3.2.4.ebuild 1108 BLAKE2B feb3b153182c585a189c91c88bf01583ddab2ccd0b0891b1b6d65a0e315646885ab9a5b55345c75e508fcc6e9136db99f30a9f7a9611d8f3ae2e7b7e3be0789a SHA512 94211308717d78375513adaadc6cd393e38f9e709f6e2571e4f0cbbe3b6c053162ac17c479adbb4aabd1cf1545eda57146cafa6b7c9c7c730f7f207c41ec0dee
+EBUILD cheetah3-3.2.6.ebuild 1109 BLAKE2B a800d38f39b7372ed7c37d3bee22b7ded7ad868eddea18d7c253be3031b29eace1c391a6842decfb1218a131a19f01a8ab41ade5ad6dd9ba24861b447c7172f6 SHA512 567457fe6bc3ccf5ab02b43bb519b31b525cf3921f1a8a6f6281377864f705c14d2fcc8551775e3224853a3e80dfe1e74a85092e5eb96ff6f00235ad11cfe472
MISC metadata.xml 662 BLAKE2B 3dfe6898c1c2b60050da8427fd4e51a07ba7870120ce491166b9fd222bbaa49e7df7ba3afafe8b159a7b60f781da67dc0dfdf03f085e813cb3f6d59169ecc526 SHA512 b15fac64b057cc9216aaa21002332ec348e89a618ba4c32dd8b9622afd17d7d8db6ef6c3e7c645ad0a03b306c50b79322f5ad1866db93f1033e69b1c7d6130a1
diff --git a/dev-python/cheetah3/cheetah3-3.2.4.ebuild b/dev-python/cheetah3/cheetah3-3.2.4.ebuild
index 392553481873..6b1ecbf74c92 100644
--- a/dev-python/cheetah3/cheetah3-3.2.4.ebuild
+++ b/dev-python/cheetah3/cheetah3-3.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
DESCRIPTION="Python-powered template engine and code generator"
@@ -11,7 +11,6 @@ HOMEPAGE="http://www.cheetahtemplate.org/ https://pypi.org/project/Cheetah3/"
SRC_URI="https://github.com/CheetahTemplate3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-IUSE=""
KEYWORDS="amd64 ~arm64 x86"
SLOT="0"
diff --git a/dev-python/cheetah3/cheetah3-3.2.6.ebuild b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
new file mode 100644
index 000000000000..fecc1a523ddf
--- /dev/null
+++ b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Python-powered template engine and code generator"
+HOMEPAGE="http://www.cheetahtemplate.org/ https://pypi.org/project/Cheetah3/"
+SRC_URI="https://github.com/CheetahTemplate3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+ !dev-python/cheetah
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( ANNOUNCE.rst README.rst TODO )
+
+python_prepare_all() {
+ # Disable broken tests.
+ sed \
+ -e "/Unicode/d" \
+ -e "s/if not sys.platform.startswith('java'):/if False:/" \
+ -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
+ -i Cheetah/Tests/Test.py || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r "${S}/Cheetah/Tests/ImportHooksTemplates" \
+ "${BUILD_DIR}/lib/Cheetah/Tests/ImportHooksTemplates" || die
+
+ "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
+}