summaryrefslogtreecommitdiff
path: root/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/cheetah/cheetah-2.4.4-r1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/cheetah/cheetah-2.4.4-r1.ebuild')
-rw-r--r--dev-python/cheetah/cheetah-2.4.4-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/cheetah/cheetah-2.4.4-r1.ebuild b/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
deleted file mode 100644
index 7af0e545a7da..000000000000
--- a/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="Cheetah"
-MY_P="${MY_PN}-${PV/_}"
-
-DESCRIPTION="Python-powered template engine and code generator"
-HOMEPAGE="http://www.cheetahtemplate.org/ https://rtyler.github.com/cheetah/ https://pypi.org/project/Cheetah/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-IUSE=""
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-SLOT="0"
-
-RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]
- !dev-python/cheetah3"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES README.markdown TODO )
-# Race in the test suite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Disable broken tests.
- sed \
- -e "/Unicode/d" \
- -e "s/if not sys.platform.startswith('java'):/if False:/" \
- -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
- -i cheetah/Tests/Test.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" cheetah/Tests/Test.py || die "Testing failed with ${EPYTHON}"
-}