summaryrefslogtreecommitdiff
path: root/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/cheetah/cheetah-2.4.4-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cheetah/cheetah-2.4.4-r1.ebuild')
-rw-r--r--dev-python/cheetah/cheetah-2.4.4-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/cheetah/cheetah-2.4.4-r1.ebuild b/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
deleted file mode 100644
index 93980236036a..000000000000
--- a/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="Cheetah"
-MY_P="${MY_PN}-${PV/_}"
-
-DESCRIPTION="Python-powered template engine and code generator"
-HOMEPAGE="http://www.cheetahtemplate.org/ https://rtyler.github.com/cheetah/ https://pypi.org/project/Cheetah/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-IUSE=""
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-SLOT="0"
-
-RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES README.markdown TODO )
-# Race in the test suite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Disable broken tests.
- sed \
- -e "/Unicode/d" \
- -e "s/if not sys.platform.startswith('java'):/if False:/" \
- -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
- -i cheetah/Tests/Test.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" cheetah/Tests/Test.py || die "Testing failed with ${EPYTHON}"
-}