summaryrefslogtreecommitdiff
path: root/dev-python/chart-studio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 14:55:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 14:55:22 +0000
commit4c51ef39a9b443061a7071e002d7daa2a4d16141 (patch)
tree048b88a0effe40564f62448a2ff2779f637e563f /dev-python/chart-studio
parentcd1445321d1a6609cc7215588a79b2232c8a9bd3 (diff)
gentoo auto-resync : 29:01:2023 - 14:55:22
Diffstat (limited to 'dev-python/chart-studio')
-rw-r--r--dev-python/chart-studio/Manifest2
-rw-r--r--dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/chart-studio/Manifest b/dev-python/chart-studio/Manifest
index 2f024e36e1a2..580479ab26a2 100644
--- a/dev-python/chart-studio/Manifest
+++ b/dev-python/chart-studio/Manifest
@@ -1,3 +1,5 @@
DIST chart-studio-1.1.0.tar.gz 51680 BLAKE2B 02aeb188dae3c1ff73faea891b0a9bef775ecac58e79ec4a43f2c0e0ca1ad71f5ba0cd93bd35779e7358b9495549915e23acb2817cb7ecd3becd4afccec71077 SHA512 1ee049b79df9e5f781cf279f03df718597ef4c0cc0dc02975a16b5a8f34f9330636453868f54e12e9ec8484a23c3481dc6a367995b359e1a4c2363860a962256
+DIST plotly.py-5.13.0.gh.tar.gz 30683340 BLAKE2B 0e2c5638c766e5da6e2067d7be270576afed984b45deec0955fa10698d37bd082f3ebc568a8290c17554c672ef9e31cee81b0fae18b9f3249591fe62510ce5fd SHA512 c874b46ac43520519951aad55f93bfcfe03910873fd273f283fe16ae2a4150cfa35104be422c21b65785c77f468f084847278f76bce3d9179cc2a339809c42e3
EBUILD chart-studio-1.1.0-r1.ebuild 517 BLAKE2B dbf476ca4b9fe3534105f60bfc3b7ebac1f626c42bfa2d10a1be76d3fe92b41ea113357b4257caf85e58728d5f2742198acacba15be11490bb815d5811da87ee SHA512 dbcb34789459491ad16fb0bb500ee25b969c32c4cfe431f963c7e711796e9b384a211756a1a8182a7d6e057d2b49ef316a8ed8e9a628b8510c3449aee788c65a
+EBUILD chart-studio-1.1.0-r2.ebuild 1792 BLAKE2B ab5a7d569f7cc72abfde4feeca30eb1fbd8dd4113386bad4da7c5ec6f56045af246fde873a450daeb360cf168df5ec1b1abcfb604e8b89e43ac9f3ba57059b17 SHA512 2cfe240ca3c6abf1b577ce95999fd2d5ed63dec8481104511b031d0042f54a4465c5df6edc343549f04aae2b57238f565bfcca8e43a04a9e923a75a15ed7579f
MISC metadata.xml 608 BLAKE2B b735f54ea7fa4dc06e9f522304a2f7b297380d6504ba8520e80d6abc31dc231154b244d3bc788dcfc8b413924c3792fdb1258739bbeb20fdcba7aeba16451c78 SHA512 909661d7e9dec9661674301c2685f1b38caf7e889c103ef89ffd84c17d4f3fad60971a904152ce01f5bc48dba7d38bbd9320a96b6340e0b71a2a3495e6020151
diff --git a/dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild b/dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..1e8acc2da743
--- /dev/null
+++ b/dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+PLOTLY_PV="5.13.0"
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plotly.com/python/"
+SRC_URI="https://github.com/plotly/plotly.py/archive/refs/tags/v${PLOTLY_PV}.tar.gz -> plotly.py-${PLOTLY_PV}.gh.tar.gz"
+S="${WORKDIR}/plotly.py-${PLOTLY_PV}/packages/python/${PN}"
+# PyPI tarball does not include the tests, sources are in the same repo as plotly.
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/retrying[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # URL is somehow wrong
+ "chart_studio/tests/test_core/test_tools/test_get_embed.py::test_get_valid_embed"
+ "chart_studio/tests/test_core/test_tools/test_get_embed.py::TestGetEmbed::test_get_embed_url_with_share_key"
+ "chart_studio/tests/test_optional/test_matplotlylib/test_plot_mpl.py::PlotMPLTest::test_update"
+ "chart_studio/tests/test_plot_ly/test_spectacle_presentation/test_spectacle_presentation.py::TestPresentation::test_expected_pres"
+)
+
+# There are sphinx docs but we are missing a bunch of dependencies.
+# distutils_enable_sphinx ../../../doc/apidoc
+distutils_enable_tests pytest