summaryrefslogtreecommitdiff
path: root/dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild')
-rw-r--r--dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild b/dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild
new file mode 100644
index 000000000000..0ecf8bd8c9ef
--- /dev/null
+++ b/dev-python/charset_normalizer/charset_normalizer-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Real First Universal Charset Detector"
+HOMEPAGE="
+ https://pypi.org/project/charset-normalizer/
+ https://github.com/Ousret/charset_normalizer/
+"
+SRC_URI="
+ https://github.com/Ousret/charset_normalizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}