summaryrefslogtreecommitdiff
path: root/dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild')
-rw-r--r--dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild b/dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild
new file mode 100644
index 000000000000..c31319b41abb
--- /dev/null
+++ b/dev-python/charset_normalizer/charset_normalizer-2.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="The Real First Universal Charset Detector"
+HOMEPAGE="
+ https://pypi.org/project/charset-normalizer/
+ https://github.com/ousret/charset_normalizer/"
+SRC_URI="
+ https://github.com/Ousret/charset_normalizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_src_prepare
+}