summaryrefslogtreecommitdiff
path: root/dev-python/chardet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/chardet
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest3
-rw-r--r--dev-python/chardet/chardet-4.0.0-r1.ebuild31
-rw-r--r--dev-python/chardet/chardet-4.0.0.ebuild4
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index 1e8f9c50416c..7dbaaf51465b 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1,3 +1,4 @@
DIST chardet-4.0.0.tar.gz 1923933 BLAKE2B 10dce34cbe6f01536a526931510ed625bc5062335e9419e24c9e48d5697ebbe70dcc54ffaa976ec153340cc74c3086627a3b1dd9e34be32c89a9a81e83fd70d0 SHA512 cb0e052fdd9fec251ebc6eb3f31ca95ece017f2bfa99122997f989286988058ed9688e49d00631c63d8e4e52da1050e23f02b28d0e739aee7302b24c8808370e
-EBUILD chardet-4.0.0.ebuild 652 BLAKE2B 8c753c3694a2c5124427df5bf58fe9dd0fdd033eced871625cd8e1953b347ae2695dce0ebe672c3540f0e46c2ed3c6e34b07e5db1cabeab1411aeef328093b0d SHA512 34b526d8d2fdd272986f0e2af2fbeb8a09eea4805ba1a68ab11dec0f911d401afdcf2adb26f5d31c488ad3c9b384e9bf68692952206dddd456d943d539bfabe3
+EBUILD chardet-4.0.0-r1.ebuild 713 BLAKE2B 974dadd27cd39dc091ebc8c998a67074e6a69026f80821f9df993c1c6521902e1c51fc91e9b3267a04da7fabc0943d330428b2a5d3e19a4c3de728aa3a4c689d SHA512 bca89fd4a01ce4f0aac433da1bfdc5e4f5ef0e3d3b07d208f537f0b54d53f20466a13bb8b36082c98ee02976d10e22ee633037c05293b7594d64b77c919f4bb5
+EBUILD chardet-4.0.0.ebuild 659 BLAKE2B fbe72d35cb021ecd92e7a3e026359d26653bda2110020a3f087d2e6306fdf9f230223ff8514db4f262f6f98f842fc1a0a55c5c88e3d25ff0f1337c029ed47428 SHA512 4117c08066efa4f926bbe57457c92879e4e6d4f035eebcbc81e59a642d630e8fd14e5aaa62d186846da680b6ab569bd1177d24b41044828b4783a28df7123992
MISC metadata.xml 403 BLAKE2B 90447dade87db87cbe60f8a0ff84e0617156551d74869306167a5c196e2f6da7746a9ae9a73624099ef7d593f1f36a476cf3b61251d3ca97daab1eccc963e08e SHA512 ed1030c49899c34998da5ed13f4c6dd297f75f5f9e0a06e51106c93579aeb0b4fe37fbea08e8e182d6480877d28a963f73f4a91402241412a22ee389179d8ef6
diff --git a/dev-python/chardet/chardet-4.0.0-r1.ebuild b/dev-python/chardet/chardet-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..a8afdd4a6f64
--- /dev/null
+++ b/dev-python/chardet/chardet-4.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="
+ https://github.com/chardet/chardet/
+ https://pypi.org/project/chardet/
+"
+SRC_URI="
+ https://github.com/chardet/chardet/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/chardet/chardet-4.0.0.ebuild b/dev-python/chardet/chardet-4.0.0.ebuild
index f8886d76e437..f69796f4d505 100644
--- a/dev-python/chardet/chardet-4.0.0.ebuild
+++ b/dev-python/chardet/chardet-4.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
BDEPEND="
test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )