summaryrefslogtreecommitdiff
path: root/dev-python/characteristic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/characteristic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/characteristic')
-rw-r--r--dev-python/characteristic/Manifest3
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r1.ebuild42
-rw-r--r--dev-python/characteristic/metadata.xml12
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/characteristic/Manifest b/dev-python/characteristic/Manifest
new file mode 100644
index 000000000000..f9bcad1a4815
--- /dev/null
+++ b/dev-python/characteristic/Manifest
@@ -0,0 +1,3 @@
+DIST characteristic-14.3.0.tar.gz 26993 BLAKE2B a24548953451da77e08678b8a204c0fc649ebff52026aafc6f80037a65f527c9a2244273420b1ce76e3ac75778f48c11bc2344296cbf34ff1e9a1e82356d52f1 SHA512 e13a86f453cd3688a74188005b82a661a9c73d9f0408d9afe9e0575e69ffe87a5327f51e2c16a9c0a653b738e7c014d5aa08e353835f0aca7897714b7ae56e83
+EBUILD characteristic-14.3.0-r1.ebuild 1055 BLAKE2B eb99095c9dfc98910fa0073f5bb6c9d03a863fe081123cb84c72729b4d7b90670f2622e916d44cc02f2dbc275f1abc1b2737f39ceecfa64c65c7461eda3f09ec SHA512 3cee167208b457c22b1d983201c3207e658e88e520abc85a14b70b039682e80e4045127e19af133977e582822e786e5cf0514fadcb196e38e104448cf6ec3c62
+MISC metadata.xml 389 BLAKE2B 0e2226a252bf0308d7bf33b34eee3f035bfd242736b91072eabd77e07216104961c45f8469dcfc3a8871cacb4ed619bebfd3443612bce85d1f2ec4d95a13dd21 SHA512 291bc593113bd6fa148fcb5f978ec1630808a0a6b4ec7fb40b00596c9cd2bd56357fa792af91243d96ac21fdab420d370c0d1f59570e739be22d81b8add56676
diff --git a/dev-python/characteristic/characteristic-14.3.0-r1.ebuild b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
new file mode 100644
index 000000000000..81a65a9ef25c
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/characteristic/metadata.xml b/dev-python/characteristic/metadata.xml
new file mode 100644
index 000000000000..4e9bbbdfe8d4
--- /dev/null
+++ b/dev-python/characteristic/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">characteristic</remote-id>
+ <remote-id type="github">hynek/characteristic</remote-id>
+ </upstream>
+</pkgmetadata>