summaryrefslogtreecommitdiff
path: root/dev-python/characteristic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/characteristic
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/characteristic')
-rw-r--r--dev-python/characteristic/Manifest1
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/characteristic/Manifest b/dev-python/characteristic/Manifest
index b1cad34e1cde..dd7999d68b0f 100644
--- a/dev-python/characteristic/Manifest
+++ b/dev-python/characteristic/Manifest
@@ -1,3 +1,4 @@
DIST characteristic-14.3.0.tar.gz 26993 BLAKE2B a24548953451da77e08678b8a204c0fc649ebff52026aafc6f80037a65f527c9a2244273420b1ce76e3ac75778f48c11bc2344296cbf34ff1e9a1e82356d52f1 SHA512 e13a86f453cd3688a74188005b82a661a9c73d9f0408d9afe9e0575e69ffe87a5327f51e2c16a9c0a653b738e7c014d5aa08e353835f0aca7897714b7ae56e83
EBUILD characteristic-14.3.0-r1.ebuild 1054 BLAKE2B de5b2c602cc1e85c71a274aafa46faf7672f50aed7aa6c43b465296d3e84a4d5efe86617f8f8cad064aed15f63c99828e1308a6f6252763bd321c4ee9d5de20a SHA512 1399f0ae486977f4abc50b4b0c011bcff8cb69e469d64d7f11c9119a13cb79a9a93a12c7d4697f283c3bd4f73855b6d47edf115424369c456a38bdff3193058f
+EBUILD characteristic-14.3.0-r2.ebuild 1066 BLAKE2B 264d4a0448f1791087f6f782c37ca348c80cb181156b3095ef91d9e79f6533e177c02c20b3223081ee7d9a48182163d7ce4ea4c8c2919741229f638ec00f8a30 SHA512 afdb1d54c922d83cf3fd747b6098acc5948f2354ded324308c73c773e324e846651e5347bb89384d299e8fd27f5135037a4d00e1f2f65750a0bc8c8adaeec3bd
MISC metadata.xml 389 BLAKE2B 0e2226a252bf0308d7bf33b34eee3f035bfd242736b91072eabd77e07216104961c45f8469dcfc3a8871cacb4ed619bebfd3443612bce85d1f2ec4d95a13dd21 SHA512 291bc593113bd6fa148fcb5f978ec1630808a0a6b4ec7fb40b00596c9cd2bd56357fa792af91243d96ac21fdab420d370c0d1f59570e739be22d81b8add56676
diff --git a/dev-python/characteristic/characteristic-14.3.0-r2.ebuild b/dev-python/characteristic/characteristic-14.3.0-r2.ebuild
new file mode 100644
index 000000000000..c13a2266947e
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.3.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}