summaryrefslogtreecommitdiff
path: root/dev-python/chaco
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/chaco
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/chaco')
-rw-r--r--dev-python/chaco/Manifest3
-rw-r--r--dev-python/chaco/chaco-4.5.0.ebuild40
-rw-r--r--dev-python/chaco/metadata.xml18
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/chaco/Manifest b/dev-python/chaco/Manifest
new file mode 100644
index 000000000000..5c4fbc91a8dd
--- /dev/null
+++ b/dev-python/chaco/Manifest
@@ -0,0 +1,3 @@
+DIST chaco-4.5.0.tar.gz 409562 BLAKE2B e2e8b51924a8df036521d5b6718449f2b6ec37bc8f4de265b51f5e960d34b42cbc1cda6acdbf6a735a153d40637a4bdf6eba99fb6eb70897a3249e79b98f7d2d SHA512 66e1d82bbbf74e143e42f92eec7c83abc6f0eef488629947422a8ab2140a5a5bacf0f4e2a79f2acb8670417c9a620c9e85f295729525e011b8a09a1ff916e8c6
+EBUILD chaco-4.5.0.ebuild 955 BLAKE2B c58f9823dac5618526b58f2b57136d4037790902674a201b17d47d9b9956236a29d7f28ee2638030901e754a5ffc8a70d2e50f878b275880ab78c872cd00689b SHA512 7f623b650a006bc9ee2d201b15c4463d4852ead0aa271d39df98ce9849cd666aa11784c09b7b12883a4faac09b7dcba47c2a31bea41eb26f09131467e6f852e8
+MISC metadata.xml 777 BLAKE2B 211692c83d6a6da300a9e2930f58dafbfc04e0ae1a97955fd613a4ebd474cf05a4872580b855ac0cd6ae908859d3cea56d5885f07f38151eae65bda45387c251 SHA512 1602b00a9250a5178744e8551531fcf60bad459c2c1582da6a310a5923c856790b4646f6442b4691fe55ff8b08230ee85f653a4dec9b4faebb355eb7afc97d31
diff --git a/dev-python/chaco/chaco-4.5.0.ebuild b/dev-python/chaco/chaco-4.5.0.ebuild
new file mode 100644
index 000000000000..798acf87ae0e
--- /dev/null
+++ b/dev-python/chaco/chaco-4.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx flag-o-matic
+
+DESCRIPTION="Enthought Tool Suite: Interactive plotting toolkit"
+HOMEPAGE="http://docs.enthought.com/chaco/
+ https://github.com/enthought/chaco
+ https://pypi.org/project/chaco/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/enable-4.4.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
diff --git a/dev-python/chaco/metadata.xml b/dev-python/chaco/metadata.xml
new file mode 100644
index 000000000000..cc6bb8178e7d
--- /dev/null
+++ b/dev-python/chaco/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription lang="en">
+ Chaco is a Python plotting application toolkit and a part of
+ Enthought Tool Suite. It is meant to facilitate writing plotting
+ applications of all levels of complexity, from simple scripts with
+ hard-coded data to large plotting programs with complex data
+ interrelationships and a multitude of interactive tools. While Chaco
+ generates nice static plots for publication and presentation
+ purposes, its components are all designed to be work well for
+ interactive data visualization.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">chaco</remote-id>
+</upstream>
+</pkgmetadata>