summaryrefslogtreecommitdiff
path: root/dev-python/cftime/cftime-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/cftime/cftime-1.5.1.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/cftime/cftime-1.5.1.ebuild')
-rw-r--r--dev-python/cftime/cftime-1.5.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cftime/cftime-1.5.1.ebuild b/dev-python/cftime/cftime-1.5.1.ebuild
new file mode 100644
index 000000000000..3626bb7335d3
--- /dev/null
+++ b/dev-python/cftime/cftime-1.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="https://pypi.org/project/cftime/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e "/--cov/d" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}