summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
commitfc7e841956ae3cc385629bf33433de23a6d04db6 (patch)
tree48882d11ff725a7df862343487d339fdaae1c604 /dev-python/cfn-lint
parentdbb637a643576bbb9286907cd6c73e3cda3ca1f6 (diff)
gentoo auto-resync : 19:07:2022 - 14:39:08
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.61.3.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index ee5dc2ec5f79..8b6690465620 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.61.1.gh.tar.gz 9351410 BLAKE2B 442fa5957f8816dc501e91593873c28b1b2e39ec14870b82574d4ca351f321b94a813fd351cc09c7602a177a8451d09cf8459c8aa47b683b9938654c99476e19 SHA512 63071cd1df0115624341fb64bd12a51d7bd38fe4993229a790ca09011b370487cb49397d90916f4df42b5c978cd3832e2de4cec15660ac8668e994adc0e681c3
DIST cfn-lint-0.61.2.gh.tar.gz 9477584 BLAKE2B 8b65151edcd9323dd44d6a77c39fb3dd90a1934bc1cf3e6cb419e6a33595afeb740591a77a80178cbaa5dadd5183759064807a5a135545c2fb7e8c5a2c8970ba SHA512 ed8e9813f1d12ec0ded203c4c2246592c2aa3466f69ee2a478d9ac579807a610836d862768c259ebec6e421bbe92a5a120c056a5e4b70873e6e044e0c606d021
+DIST cfn-lint-0.61.3.gh.tar.gz 9528542 BLAKE2B 27f5c82c09a7c1dde520189647480032faf808089083ca45a9a2a24e4c158cb8e62ee6ae2f906d6c68021cc34b654ff46c9402876e09dd3330115dead5db44a8 SHA512 db5369a12d88754f6241b4ef529b53d142a80bfcb0c58ac7ec03217e7e4cb7e53f3fde1dde45dfdac82ab3fde4b885bb40dae3076b85edf34ca68cc73dc5aeb1
EBUILD cfn-lint-0.61.1.ebuild 1638 BLAKE2B 890ffa9d97980c5fcd532b44c93c9ce851c0ba38214f7ed6ecf3e68a64c1a14adde34594d9a111987a6740fc06dc30d533e9bdfb46f5bbecb6d6563991975b13 SHA512 a298830dc9249612b174d764b201c5e3c65504ae86a40a81453c13ffff12de4d5e79e7110edeb3645a403f94f781fb53e7e850796199d71a386ca99cc2bf0026
EBUILD cfn-lint-0.61.2.ebuild 1640 BLAKE2B 1c8eb1a6a2321d09f163cffb42d2af24ea43571504519d9fb0c28063d2f5e2d7e8da4b38f814fd348a7cc2a317ddddfab7429376b852febddbfa9ff6c52bff2a SHA512 e13621a54e1eeec34bbf2d9997177d6c0af4a7917c13e13d36d32cc1b07e919012faa58e9599c585e25992fbeb11cc5f7aec85e20d0f54c69d647dc093ce38f2
+EBUILD cfn-lint-0.61.3.ebuild 1640 BLAKE2B ab0b276a17eb6e1736a03f89d00a70a55840063177efdb4ca391f399acb5dea04480b4a31bf9bba12c607f35381d95b44dd6e346141d9e7e084eb4d48fe829e7 SHA512 ebc9ee814224010bf27a5e9675de5e1eed72073441da99ef9b8a3f8c17041eb6855d0951d97aa9e7f6f3d5aab758d594cdb3c93d9d990b4dac990e0fb9434a9a
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.61.3.ebuild b/dev-python/cfn-lint/cfn-lint-0.61.3.ebuild
new file mode 100644
index 000000000000..57fd1d8c6029
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.61.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.47.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}