summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
commit8e95bde8579d855189ccca3e693b4e3792f136c2 (patch)
tree4202dc7a3017eba106e5c5c5a41bcb3d08281143 /dev-python/cfn-lint
parent25e5a6599437664a3eff8d9f8a966adc896e09e8 (diff)
gentoo auto-resync : 11:12:2023 - 23:23:25
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.83.5.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 5e462f1be7f6..7acd98e7be77 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.83.3.tar.gz 3683221 BLAKE2B 57e3d093eaabb4907cacd9908cadc1268600423e481316dab17da52f50472634e2114ab4069a9f68db440be1a76c4c96db9c53dd6991524bf2cd3699f8e5299b SHA512 6c47fcab3b077ea7ffc7f7fab695f69d2e4a00eb85c2db7889235b0b41b462a92293e538640df190871148ab6f779570385787bed161db0f65efa289b4b4803c
DIST cfn-lint-0.83.4.tar.gz 3715966 BLAKE2B 5e30c43ae9fec958ef048eeafacb9d05a00732bd79446ef652f9b3d41f9bdd262b35b028c6a20a5f93ec46cc8da0e8adfad5d87129a5d591812a89c4ced0e619 SHA512 d3dc80ec99959c4112a7bd87bcab9f261542f25c4529df9a8e5745901e1dc4a8ca94bdec829f8042a7f94eba6021fe08975e06d4596993a7a319ac861897e2cc
+DIST cfn-lint-0.83.5.tar.gz 3779609 BLAKE2B 7ef8032e53a430fbcd7407b9573956ddd09af02475c0ffc730c6e26cef6eef97ee770b974b5e109ab1759e33b1ec9bd8b17c94a218e0c041bb2b0c53cdd3df32 SHA512 bb27abff9161116fc485301397321922e56a8c0f8382d0d28b82671d754907d0bd80c1c90d03b98b745d90807c8c3f4ebffbb8a78f219b86a489094c2184f17e
EBUILD cfn-lint-0.83.3.ebuild 2065 BLAKE2B b134a28d19b071032a90a829c12cac55244cef9bc58c79caa85fdeb1fea35c3633dbcf8364356cd1f9181694c676ea60b55779253083eae1d51d6107df52694b SHA512 52d6fd15e6797d6a46616ee5ef871cc2442a5370a74e037d29eca0250deeee13dc9a597f5a4ec3843f9a8c2902149c3ea5f2d3e40b60355fbca6e7cc3913586c
EBUILD cfn-lint-0.83.4.ebuild 2068 BLAKE2B a9ebd8524305333a51042099236084d9f73382fe14b9b5fd588acaf2cdc5fad3e3bea01621f2c0c5889791d260cb6b85a9c1c11e9ac1568a830c0452efe3af37 SHA512 7ac3e54970c3f6f25d471635cb81b1d56957fd6bc384ceabf77d588f74bf9e5a3ff02689806016dba343df6c71a3bd6b68e29481225558302a37ea47800f3e6e
+EBUILD cfn-lint-0.83.5.ebuild 2068 BLAKE2B c241f44b7ecf4658802fef18a1d11f582f4f9cade4b44821da2cded6d86fb745dc23ada51e4d450e6ab2f80153973d13b0569ca73ee9b41dda2451510aaf2936 SHA512 698de497f40fda671b236fb48d60715680fd9d7ddd6ee973977e95c1d45f302da6f6cbad5a2fbc103a9686c1de2f3d7af0388ead0cabee8e41d721ec49f8c7ca
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.83.5.ebuild b/dev-python/cfn-lint/cfn-lint-0.83.5.ebuild
new file mode 100644
index 000000000000..e2469d645098
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.83.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.81.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}