summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
commit88a7ab8599213acca9dd34eb21748ff54d7c190a (patch)
tree7b0906984ae3d3754da31f07f7c730f719d2f92a /dev-python/cfn-lint
parent942c9977e0273ee6c6bd3f9822263aaeab1b69a5 (diff)
gentoo auto-resync : 18:01:2024 - 08:07:22
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.84.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 0b92540b6b85..52b4b4801595 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.83.7.tar.gz 3875386 BLAKE2B 52a3a4a4a76a787b39f17e4be1e1ba2920b3579bc99a82890d9ca21ed38240bf51eee7a04d2c97b31031816410439716d5623aa55b1bd02802ba456dd9e0bc2c SHA512 28b6aaeb77cb4e5dc40234c5bdfbe9e3be4d0ea17ae4f6b68a381365f6097f51163cf5b23d1c0e98b7b9c6c53fe9d139439f84bf353c1f7d128a4d52d701c937
DIST cfn-lint-0.83.8.tar.gz 3901954 BLAKE2B 33d728ddf7ae5bcb29fdb8211decd85b72519acd60b80831aafa59d042105af45a3f07e2d6ea9838b80af68f6eb19ba84be562e4a7104c64b68737ede3497b0d SHA512 f520f5e211284197ff3b2c5287cb72384544a273e1fa1d3007e7a3ad85ef1b4bae4ed0c0db609989ea51de29630454d97ba13a8d97ccc06992a7fb0da467e0b7
+DIST cfn-lint-0.84.0.tar.gz 3890781 BLAKE2B 160c8f29f2551c0885d784d725e5e7077aaf162b13f8bcbe8f04c2f6dd939bdb22166ebc3fbba6ba71b0ec68356f520ae1968a447a7a24082eb85271c684aa1b SHA512 0e783c6c2fc590ce59526da887a3bdcc2f8c55e6d5d6e11f49df82c72d387a18abbac545b861bf806e829080b7be6da00d948d32769396b6730570ab4bc23f7a
EBUILD cfn-lint-0.83.7.ebuild 2065 BLAKE2B 1c74b61135135c68cda92c13305673d9cf690f3ea6882c63fcfe51c0570ed87ce3843670f7c2f085a7a52b34e2b947f931ffdfb1f2ecad6a79fbb575370027cf SHA512 a83f63069afa0ede0760b3c4df18f2e0a045ba5dcbfed2c8486cf19df39eaa431d298e3cce5be92b588ef01dd25f86e5201e41b9d331ba2877b84c790e81727b
EBUILD cfn-lint-0.83.8.ebuild 2068 BLAKE2B 0af0e2d2c3a19d8c8110a7e3da04001309563a3807883e2ba31adaff4bb8cb8e5f4d8db43a5da8499ba76657f82c9a443661c50f0690820159ea504a1de7e632 SHA512 02b826b46333cc3587fa2d6a61c80484a862c4e1da15f9950ab7187df9a05fc3b65e5f82cc4938a6273c42c1e439350109bede3993a1138c078eb80379e2cc54
+EBUILD cfn-lint-0.84.0.ebuild 2068 BLAKE2B 4be25b16d34d30034f7e5c43d560ed65ca2ebbca0e166d660060ac829f391c641c769e7b06b947a7f10074cc7c03fcdfdcd5c128aed4f20b59327119fc7cc731 SHA512 86404cd0719ff5125a08605d8c22387c33cdc3be845c29eccc799fc1c125dda859798046b956c768b28d0639d86eae9324e2d1ccde5953a3c10f08c7649b7350
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.84.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.84.0.ebuild
new file mode 100644
index 000000000000..dcc388673e1f
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.84.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.83.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}