summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
commit2c359e29620429f94a60fc1e832048e54ee41eb5 (patch)
tree3a24152899725be0796179577e84caf957a80ce3 /dev-python/cfn-lint
parentd6a3ca89e16356791af128f18ca5d5aeaf1323e0 (diff)
gentoo auto-resync : 08:05:2023 - 23:39:55
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.77.5.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index c4ab0d6b45c9..e1b63ade5359 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.75.1.gh.tar.gz 3487870 BLAKE2B 26aaf3b24023260d7a7d8f2b89fc9135e0c34786540c21d1c1763decad42167f1a29b01859bfcb17fe5ac1fbbb08aebf04191c6d1b21b335c92e2424c986cada SHA512 d4dfa9331c77f7c323b217203c470e15b4a62a86b42497934a4f9609d54a499211058cba4c561034f6c3dd6ba52ade30084e9a9d25da135289f783ed972a14ae
DIST cfn-lint-0.77.4.tar.gz 3510766 BLAKE2B af5f8a842863504217b90cea80861a889eae2d1bbe1d7c8c9b429acaee00d291ddbe71e868577acc689a1ff04aaf9c5b2f690a839235cf57202b6226bc7f1abc SHA512 96fe05b91d93b2581f546973bf0a812184429cfefb26c69e8e14fe6ac6402219ab518777a3f54fb30092c30189486aacd0841d1db31a191697ad1c333662bb98
+DIST cfn-lint-0.77.5.tar.gz 3513226 BLAKE2B edff62682027d87fc4f0934aba83ca1cbd83773fbf85246eecfe1d1908b8ba0f6df413b2dbc8976770f7eefaec78bde1cd7017ed36ffac849687436364a42f2d SHA512 e80231e8539735d0a114c6de81f9c52714a1886dbeb070b78bba3c9dd2798399bbb6eb41b3917b5c826b4d3d571f2d9996a5eeaebd7a48a9b774135fb0966372
EBUILD cfn-lint-0.75.1.ebuild 1594 BLAKE2B 537ab8571cbc50fdde95e0901af7a627c3eb92a125f8c33dcefe96ee30b8a95e548fee0a33431d7034c44521bf5581a964770a36df863dab1ed047107cc2665f SHA512 3a7053518919d0c806d80ed768eeb869ab00a88b891a1783e10b425550a481d978c516021f9f37c7e30ae5b055eb9683d7a05cf3edd17ccea2fd1813b0405c66
EBUILD cfn-lint-0.77.4.ebuild 2011 BLAKE2B 9380625c02bbfa616e3d71e5b7688325852b6976863ee5d666b770e999c7faa3cf9c613ec366f800ca09db208c590986d942d506b27539539910885df506e8e0 SHA512 8985e25ab09102e75e67aa318db1b8652f048fdc3432370a6ca0308422c61a3afa3044e4098ae40be10c22f260e7d4bf81372a41192ba0cbae7576a8f67bdbf6
+EBUILD cfn-lint-0.77.5.ebuild 2013 BLAKE2B f530e08427d10e913795201f7c5ec4747a1077ec38e4243163ef8c6d25b8d9336aa87c732844dd687140a7a0dbe558e8b3825c72faf8563458c7518eb61178b9 SHA512 e0b0145a72fc6cfcbb14d55d95b55ec7e58e95b43c6a9762d3901a0352c4d0f490b8f13400fbbdcf0c92f4b1f5d281b5960215bb45908ae956b3e0d3d74a7c92
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.77.5.ebuild b/dev-python/cfn-lint/cfn-lint-0.77.5.ebuild
new file mode 100644
index 000000000000..aa05429c93b5
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.77.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.65.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}