summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-13 00:08:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-13 00:08:30 +0100
commit0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (patch)
tree941e6ba8c256dd27e9f9ca634f08d4bf0278798e /dev-python/cfn-lint
parentf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (diff)
gentoo auto-resync : 13:06:2024 - 00:08:29
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.87.6.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index ad0dca4e1e1a..e097f300c862 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn_lint-0.87.3.tar.gz 3963065 BLAKE2B 400532698248204fe2bbf9f29fb374d178cd4a8b168dcb681b284da0d5d7be17cd28292b8f37a7c600936b96a56e90d925e5e0d88f062f5c8a7821f0ffe43528 SHA512 b23ed7259907da993469b4b2a6cfb6a5b8f1bc9186d65e8392ccf628b8b37fe7a0bde6d5d57ca6924d738770367e67245f13abce4777fa88945316569eb59b4b
DIST cfn_lint-0.87.5.tar.gz 4059125 BLAKE2B 93d1b6ad445628360f62d1d4ceab75af85c1ed8ae9b5ac667f70346e5ddb6e75cac57544f5fb4f1f44d30503041c2259a4cedcd4be343eb7408b6d82a9e2fe9a SHA512 3a1fc8514a9490544190e6f8b9d1333676683ebdafbe040660558f9c2cd3675494ac44979019f1fc57857cb692ee32000e60218a9abb959e686949ff032e6eb9
+DIST cfn_lint-0.87.6.tar.gz 4076995 BLAKE2B 57a5d598d2725851d1a59094bda249b32f7426381224cb8c2e6701e5eea92d0aea2984a5dcc6eb1640194e2535c9fd570712d80620c86fb20fcf42938942fd7a SHA512 06f3a51487ec19a4288ebfa87d6c00bd4fc2b3bfc81299c23e3afa7991ac1234e772dd989cf94af21ee3fa7d236fd9d36119e34d6d57f8da0ad304cb754a3326
EBUILD cfn-lint-0.87.3.ebuild 2040 BLAKE2B 836c0e6de223292a40d126bdbfb74ffdda1e8d78740507e7dac410e039ea8f6904f56e93588f3588de7791454768fa2bf75ff60b007e61482a929b0cdf7838ed SHA512 482bb0a57a3ee1ced1a1e39e7f45b588ff5dcc5931b5262c3575390f4b3cd43f3983b8a27884d2049c7e2a5886ede4b42d6610153adfbf4704e60154a415fb98
EBUILD cfn-lint-0.87.5.ebuild 2043 BLAKE2B 02f4a43649563ef965302d40bff0f6b8bed6acffdd2f3aa54670816062f1b5dc3cf26112d8ca31d002acc00f850cf3d19c8b75f948b4bfdeb46bd1d8f45ea568 SHA512 f24a5e9e4fbb1bf94117513d19ff04f2e26cf4da1cc57aebc6ae3da509ec5e4bc3c01ecfc254a1f1b7b1cad6a2aa16ca6c8e0fcb3d33af8fa6e359c1eda60932
+EBUILD cfn-lint-0.87.6.ebuild 2043 BLAKE2B 02f4a43649563ef965302d40bff0f6b8bed6acffdd2f3aa54670816062f1b5dc3cf26112d8ca31d002acc00f850cf3d19c8b75f948b4bfdeb46bd1d8f45ea568 SHA512 f24a5e9e4fbb1bf94117513d19ff04f2e26cf4da1cc57aebc6ae3da509ec5e4bc3c01ecfc254a1f1b7b1cad6a2aa16ca6c8e0fcb3d33af8fa6e359c1eda60932
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.87.6.ebuild b/dev-python/cfn-lint/cfn-lint-0.87.6.ebuild
new file mode 100644
index 000000000000..1965af60837c
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.87.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}