summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint/cfn-lint-0.74.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
commitcf5d856691cbc347f5816a181e5bf767792afa55 (patch)
tree239945541c80dfa78133d5e9ab5c52c25a222b09 /dev-python/cfn-lint/cfn-lint-0.74.3.ebuild
parentbb007f0b04c719fd2b846d177c3c4739fdb7c318 (diff)
gentoo auto-resync : 15:03:2023 - 12:21:13
Diffstat (limited to 'dev-python/cfn-lint/cfn-lint-0.74.3.ebuild')
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.74.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/cfn-lint-0.74.3.ebuild b/dev-python/cfn-lint/cfn-lint-0.74.3.ebuild
new file mode 100644
index 000000000000..8354055752aa
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.74.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+# pypi sdist is missing tests, as of 0.74.3
+# https://github.com/aws-cloudformation/cfn-lint/pull/2630
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.60.1[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}