summaryrefslogtreecommitdiff
path: root/dev-python/cfgio/cfgio-0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/cfgio/cfgio-0.1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/cfgio/cfgio-0.1.2.ebuild')
-rw-r--r--dev-python/cfgio/cfgio-0.1.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cfgio/cfgio-0.1.2.ebuild b/dev-python/cfgio/cfgio-0.1.2.ebuild
new file mode 100644
index 000000000000..0a3e2bc56add
--- /dev/null
+++ b/dev-python/cfgio/cfgio-0.1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing configuration file formats"
+HOMEPAGE="https://github.com/ercpe/cfgio"
+SRC_URI="https://github.com/ercpe/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}