summaryrefslogtreecommitdiff
path: root/dev-python/cffi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/cffi
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest2
-rw-r--r--dev-python/cffi/cffi-1.13.2.ebuild43
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index fabe68075b51..f504495a1f36 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,5 +1,3 @@
-DIST cffi-1.13.2.tar.gz 460243 BLAKE2B 74603f2b1bde068a955e94912488fd7d8914267ec2d0cbd8574f62376fc24ef16d85d59e9fee7f6015e6d242726ea25235788faddedc68deb56ae71e627d6322 SHA512 2c57d9c06c39e95498a54408dc39940427190f3c03e1b8f1a3584140db08a5775dd12e6e67b03093429c130af579d01519b0fc868b99ba7a530068ed22d38522
DIST cffi-1.14.0.tar.gz 463065 BLAKE2B 4d1e8a92241db801848ef8bd05ea15a31c7f61ea426ce4da184aff00df786348d2c76de9dc48898c814478aed9750b665868df24ad39435062cd7e1c84163e52 SHA512 4c5451eeede1d48a8f4b40e25b845ad1863b8bf3bd39624e6c693c2800d89a13efedc4c43b37e317a035613bffc2e3fd5f7e583c46cb283cb5cb930356f86253
-EBUILD cffi-1.13.2.ebuild 1286 BLAKE2B 034b35097804c1f4fdef63a5329792f370cf938692551a4c2cb5711662b524c3b9f397e49df012d32dff1975bb0d5d7dacde2ae36ab35131fcd7678082187553 SHA512 34f7ae95905999ca622344b8017d38436711e14cf729cf97193db99789aabc2ee4bc14528f3e86f8bdc466d1ca1e1d77c4b64602717392db83b1ca3a70b19237
EBUILD cffi-1.14.0.ebuild 1286 BLAKE2B 034b35097804c1f4fdef63a5329792f370cf938692551a4c2cb5711662b524c3b9f397e49df012d32dff1975bb0d5d7dacde2ae36ab35131fcd7678082187553 SHA512 34f7ae95905999ca622344b8017d38436711e14cf729cf97193db99789aabc2ee4bc14528f3e86f8bdc466d1ca1e1d77c4b64602717392db83b1ca3a70b19237
MISC metadata.xml 317 BLAKE2B b6416209bd2358c42c2be3bd228238b401bf126919b6e7371d83d7cec8cb55a40f89db562701cc8f3dfa904e225426881b22ff1d3b72085365b5caf9b8c6a403 SHA512 0744ca7b98b2ebe2985bf2a81a337d09be62cfaa51f8380bac52f8d30941e997f09be20e28caf6967226a71369003cf35977790aba56ed0d469cc490cfa089b6
diff --git a/dev-python/cffi/cffi-1.13.2.ebuild b/dev-python/cffi/cffi-1.13.2.ebuild
deleted file mode 100644
index e603db86aa4b..000000000000
--- a/dev-python/cffi/cffi-1.13.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="virtual/libffi:="
-RDEPEND="${DEPEND}
- dev-python/pycparser[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx doc/source
-
-src_configure() {
- tc-export PKG_CONFIG
-}
-
-python_test() {
- "${EPYTHON}" -c "import _cffi_backend as backend" || die
- pytest -x -vv \
- --ignore testing/test_zintegration.py \
- --ignore testing/embedding \
- c/ testing/ \
- || die "Testing failed with ${EPYTHON}"
-}