summaryrefslogtreecommitdiff
path: root/dev-python/cffi/cffi-1.14.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/cffi/cffi-1.14.5.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/cffi/cffi-1.14.5.ebuild')
-rw-r--r--dev-python/cffi/cffi-1.14.5.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/cffi/cffi-1.14.5.ebuild b/dev-python/cffi/cffi-1.14.5.ebuild
deleted file mode 100644
index d329f87995f8..000000000000
--- a/dev-python/cffi/cffi-1.14.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-libs/libffi:="
-RDEPEND="${DEPEND}
- dev-python/pycparser[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx doc/source
-
-PATCHES=(
- "${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
-)
-
-src_prepare() {
- if [[ ${CHOST} == *darwin* ]] ; then
- # Don't obsessively try to find libffi
- sed -i -e "s/.*\-iwithsysroot\/usr\/include\/ffi.*/\tpass/" setup.py || die
- fi
- distutils-r1_src_prepare
-}
-
-src_configure() {
- tc-export PKG_CONFIG
-}
-
-python_test() {
- "${EPYTHON}" -c "import _cffi_backend as backend" || die
- epytest \
- --ignore testing/test_zintegration.py \
- --ignore testing/embedding \
- c/ testing/
-}