summaryrefslogtreecommitdiff
path: root/dev-python/certifi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-python/certifi
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/Manifest2
-rw-r--r--dev-python/certifi/certifi-2018.8.24.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index 85916b5e465f..6c9c7d278562 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1,4 +1,6 @@
AUX certifi-2018.4.16-use-system-cacerts.patch 340 BLAKE2B 42278c6b40ef6daef71a2ef3da75baf78833906c1cd018757b0b45d8ca623cbb5de15e5d5cfa444eb360738b368ad2111bb5594beaeb910275c65267b7532a34 SHA512 8c0b36be0ce23132fe739be4a173f537f4f8870fe0f5e2c98add13e94c0c23490cd0aac30e289193820790eb8580770e178e32b9f16b28255fd95565d6015faa
DIST certifi-2018.4.16.tar.gz 149967 BLAKE2B 4a69ec495266d54032dfabc9c17d0b1e78ad1467214f9f981feb4fae279c1f4b5f0bc3f7a643c2229b17d19e32c1ea894dc16d73b036a0b32f17faa9ac55615c SHA512 96369b318df9592ed4ff48d79ae695f89d27d85e8f5de72548fccb19ac15b83a33fb8bc096a3092d7a7f5b201af08805576888418c7927cf48b892df56464682
+DIST certifi-2018.8.24.tar.gz 146866 BLAKE2B 92a609bffd777a624d18e612e2fa504b1cd4f0764f979d22bf6785158fb928d30984fba16b839f6b4066395dadcca485e6215c6f0b6b550d891673a79ea77c08 SHA512 bb0af24570dd4806bc80cd438cae42db82f820de815a6148b184f58c19cd91a03f9275815559817a84220dcbd7c87a4a7d12e35cf4a95a1dbad286a1dfecf907
EBUILD certifi-2018.4.16.ebuild 1421 BLAKE2B cfbd3cef82853456e77532e59cddc6470e01afb64eed3a7831bc315a0af5394dad581d0f161a5fb1a92845e37e1ef715e568e71fca4990b9c9cd9b8b46761147 SHA512 8833454c9744ce1254134bf2280675203c632c3a002562c4c20d5d774a630f1c63c8ed9563abb8188dfc73c47521fa17370c496093d6c2f19774cb3ca8c1ba1d
+EBUILD certifi-2018.8.24.ebuild 1434 BLAKE2B acd141ad3999e000f89c426adaec0005aca0a1821ac3e2e001f39397b3395a451d43800fe09782f47b669cfb845bac1c2c3aa19825ab02eba12539b43c1f2ea5 SHA512 587c96b2d36b02c69024fcc85b71a240adc63b05bc692edee2d0d25b0f58fdcd7f421173da0c13bde3a90bad70910c64c3dbf1a2b1954bf9c9b0fa52d26857dd
MISC metadata.xml 320 BLAKE2B ba5c3c1018c5cba293969a523ab6c388f5bc0d0cfdfc69a4b143f1c966aad036df449bb091eacdeae2335a6bdc722da85882caad2a447bf87b600da2ed7c5309 SHA512 0e99564887f0a0b314056b2e1f4b6e3afcaf908de6824a2cc87deab9d1832566e97b8ba88cc7d2bdc5d11e7f1c8532830fc59602efd8c2f1a6061c0ad4853fdd
diff --git a/dev-python/certifi/certifi-2018.8.24.ebuild b/dev-python/certifi/certifi-2018.8.24.ebuild
new file mode 100644
index 000000000000..37a29cb5a006
--- /dev/null
+++ b/dev-python/certifi/certifi-2018.8.24.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 prefix readme.gentoo-r1 versionator
+
+DESCRIPTION="Python package for providing Mozilla's CA Bundle"
+HOMEPAGE="http://certifi.io/ https://pypi.org/project/certifi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-misc/ca-certificates"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Do not drop this patch -- this will affect system's security
+PATCHES=( "${FILESDIR}"/certifi-2018.4.16-use-system-cacerts.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ eprefixify certifi/core.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local DOC_CONTENTS="
+ In Gentoo, we don't use certifi's bundled CA certificates.
+ Instead we remove bundled cacert.pem and patch certifi
+ to return system's CA certificates.
+ "
+ readme.gentoo_create_doc
+
+ # Precaution -- nothing should use bundled CA certificates
+ find "${D}" -name 'cacert.pem' -delete || die "Failed to delete bundled CA certificates"
+}