summaryrefslogtreecommitdiff
path: root/dev-python/cbor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/cbor
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/cbor')
-rw-r--r--dev-python/cbor/Manifest4
-rw-r--r--dev-python/cbor/cbor-1.0.0.ebuild19
-rw-r--r--dev-python/cbor/metadata.xml29
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cbor/Manifest b/dev-python/cbor/Manifest
new file mode 100644
index 000000000000..8696e63bb820
--- /dev/null
+++ b/dev-python/cbor/Manifest
@@ -0,0 +1,4 @@
+DIST cbor-1.0.0.tar.gz 20096 SHA256 13225a262ddf5615cbd9fd55a76a0d53069d18b07d2e9f19c39e6acb8609bbb6 SHA512 996b61c7d16cbe8bd7b056d09286a17f3a6a29cb97ef9e5ca1d1bfe8c53393ae3d2b7565c937a283cb78f377af14c070bd663aabbce995dc7e5b9d2f69a6ba73 WHIRLPOOL 5384cf292f08edb15e53d35ab86feeac6e25c967a5a3a0e1e21d3f0a7460feca4b2e27d3ace58a05c4a0d751b0f5719a24d174e5d899818c6890ad139e1cbd36
+EBUILD cbor-1.0.0.ebuild 475 SHA256 3eeca865b6e5abec490cf3f06a227d8427fa91aef0c1506efbe7d67e76667587 SHA512 dd6d95543572af1c58e684660586111eb84a080f1c69b4f957517b3d2ed54c046f96c96edf551d195915a750425ef03eefc240bf18699abcfcc1c47b3110afd5 WHIRLPOOL 5f854b944ee72cb495c2eebe91056a3d666814b43b5b2d6f61257420b3703b9411331f1dd622ada52b4ae866dbadea29a858a21e137312bae95e592c905a344c
+MISC ChangeLog 466 SHA256 e3ef3a8f33e01901c6763648b023939c3a1d7be6cce0a1cb25bb41d0b3f8439d SHA512 f3209976fa8bcf6ebd6bb925df611b9803656071f9fbdd43a5a810d576dc54542e4abcfef75729e5fe706f2abcb84b820194a7c8f61195a1943124a946d16e04 WHIRLPOOL 4897e06334a0fc9a01520e559d3338d1c8b4b210cde394d112577165248f319e461202035bcd26617f214fd9681e2196b89822a8f1dd2e010daf547cb324b666
+MISC metadata.xml 1122 SHA256 ff87d188a4f3a21c351d072061787feea0d88206245dd1e1d2ffc39cc36d20fb SHA512 1ed4417585efa79ba5b548ac90336ca7a9ca9d6e1adc7a53641d0e48840bb97532f718bab5cf4b7b36b487015c1d7cbf7e8f5d6491e698b99269ff6ec0fbf5e8 WHIRLPOOL a00f1f4ca30e0d94f33993115b3ce2d8ae7aef320283d3780e5cdbe383c402adef2b4fb614596e6a325f5f12e47c24f18043f07977671869c288eb84352383ea
diff --git a/dev-python/cbor/cbor-1.0.0.ebuild b/dev-python/cbor/cbor-1.0.0.ebuild
new file mode 100644
index 000000000000..c651b7d6be55
--- /dev/null
+++ b/dev-python/cbor/cbor-1.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="https://bitbucket.org/bodhisnarkva/cbor https://pypi.python.org/pypi/cbor"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
diff --git a/dev-python/cbor/metadata.xml b/dev-python/cbor/metadata.xml
new file mode 100644
index 000000000000..0108109a8853
--- /dev/null
+++ b/dev-python/cbor/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>bolson@bolson.org</email>
+ <name>Brian Olson</name>
+ </maintainer>
+ <remote-id type="pypi">cbor</remote-id>
+ <remote-id type="bitbucket">bodhisnarkva/cbor</remote-id>
+ </upstream>
+ <longdescription>An implementation of RFC 7049 - Concise Binary Object
+ Representation (CBOR). CBOR is comparable to JSON, has a superset of
+ JSON's ability, but serializes to a binary format which is smaller and
+ faster to generate and parse. The two primary functions are
+ cbor.loads() and cbor.dumps(). This library includes a C implementation
+ which runs 3-5 times faster than the Python standard library's
+ C-accelerated implementanion of JSON. This is also includes a 100%
+ Python implementation.
+ </longdescription>
+</pkgmetadata>