summaryrefslogtreecommitdiff
path: root/dev-python/cbor2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 11:59:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 11:59:22 +0100
commit6abaca02d36f161c81e2d5ee467719a89f88b2c5 (patch)
tree3caa7c096e2eccd186e20aa71bda508c5c50fb23 /dev-python/cbor2
parentb49088575eb777ced2551f484da86317332d6087 (diff)
gentoo resync (2) : 24.07.2021
Diffstat (limited to 'dev-python/cbor2')
-rw-r--r--dev-python/cbor2/Manifest2
-rw-r--r--dev-python/cbor2/cbor2-5.4.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
index 4cb4ec98f537..d2b4e4e76dc7 100644
--- a/dev-python/cbor2/Manifest
+++ b/dev-python/cbor2/Manifest
@@ -1,3 +1,5 @@
DIST cbor2-5.4.0.tar.gz 84850 BLAKE2B f615667fbf0a823606d55e36de42af6ff4cdc0f039e540750ec2663ba660bf11f26b75ed21ffa61ba6de05fcb6eb76982757321430506a4cfde11c1487cc788c SHA512 9fb110ebadbd803af94bbe5b6f35bf6d28dd2c30609d1bacca08dfa01efb07e670fee72aa29010ef6c64051eda6e772d3ada0fd64c444ccc0e94061483131c60
+DIST cbor2-5.4.1.tar.gz 85777 BLAKE2B 7e81436c066dc245038fea6c5c8fb25ad87aae4c8b0a4d3e8ffa1a262dd4b08c6b0d8a79214dc13c87dc4ab6902b7762847b75f217a83769ef97783e2a25a6f4 SHA512 40aa8ad631eb6ba9a59a70fea4c6871057401550d7b4b59846e06b8a068458957beac9de1b811c8a9ca377ac06120efefb527e9a280defb55eb5767110ccb62c
EBUILD cbor2-5.4.0.ebuild 669 BLAKE2B 94402bbe05e2501dce140e2dadfcdc5da42a4c945cfd8760e1701d9688ea19eb8fdbb65337c3a53fdfd6375c452906369cbd3d751305580aefa64e9fa4946002 SHA512 65336ad97d2334d121ad28cdb5b0508c6c8b427db4522c5242363457679b8d64620121b77c3f3f26e2695e11740f189ac74c78446e915d78b437f89733485e18
+EBUILD cbor2-5.4.1.ebuild 673 BLAKE2B 8a1bf7da29e826b928b2d3e1a4cd6f8cef99d1d23d2b170d6b9cfca894af0591d34d689849c33766dd2855efd91052ae29c20c30a96756db5a18c2cb3e90c034 SHA512 4851aac5d714324213c11cabca52548d89cfc2f0e178f27e03c9f0bc8de0080e19250a8f59920258a4166b22defea6b77518a8a4d2599dcab997899c6f625159
MISC metadata.xml 994 BLAKE2B 1cbdb43b43bbbdc4eb6e316cca38500fcb11bcb2f4114ed4febda09976b992c5e033b42a8d2669c785a54d310c0513fa665b77f40784a91244942556c8dc0a61 SHA512 977635a48f9e914c7c6d9cdb7acdc4db5eef968214a3e814bd448fda55f418402672f58405278e3594b43cd72825e053cff0a3a38f31d556fb898a190755a4b2
diff --git a/dev-python/cbor2/cbor2-5.4.1.ebuild b/dev-python/cbor2/cbor2-5.4.1.ebuild
new file mode 100644
index 000000000000..62a624ad6206
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -e "s/pytest-cov//" \
+ -e "s/--cov //" \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}