summaryrefslogtreecommitdiff
path: root/dev-python/cbor2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/cbor2
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/cbor2')
-rw-r--r--dev-python/cbor2/Manifest2
-rw-r--r--dev-python/cbor2/cbor2-5.2.0.ebuild29
2 files changed, 16 insertions, 15 deletions
diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
index b9708addf93c..9564c56e94d9 100644
--- a/dev-python/cbor2/Manifest
+++ b/dev-python/cbor2/Manifest
@@ -1,5 +1,5 @@
DIST cbor2-5.1.2.tar.gz 73247 BLAKE2B de033651c0483aee4bb3bb31f9a997bdd6329c2941dbde65acabe7f7a3bfde37ab0322085a3107fb581e36cb6792cfb4fcf07cdbedfcec4a18a907582081d141 SHA512 81e4c3e8c727fea6db8bbed657806ace8777d8ad157395de3db7f0dab369abcd7f173f0cfad538c325a49bf90b450eab16ad2f4aa4f69c324dd0807ae0ab556f
DIST cbor2-5.2.0.tar.gz 81467 BLAKE2B ac35cf682f15eba2c2bff81f562fe2f22906ab8da39c04cbf65f403eeacb5e640e200b15a8cca0d7eede1d0106cd8674640b3093d166a4414a2d42452a374322 SHA512 101aed37c3921ace2f4a5fbb9964ddd2ec2ffcd23fb1a9f838b2f8925f17ffaf5eb39a40b5426e176f0c97a2ba1d3a045e96ceb53312b283101900eddacc6af4
EBUILD cbor2-5.1.2.ebuild 791 BLAKE2B 4857cc41aea07863c682974d6fa84cfdaa2924f7bdbb434682fbcfd681ef142debb90ba4eb8a8bf21a80be3479aa0fe11b35bd942b2304a60cde081267637c01 SHA512 faf1ae283ce86f9d59849e32e618c5380491511d8f9daa45b3fb64278e214448ca9032064ff632dda825e4f5245b8b4336ad9c6140cfea2cd8bb428b683c0033
-EBUILD cbor2-5.2.0.ebuild 774 BLAKE2B 0170d1710b721f70ba757f8e3909e356936e4de08cc7e0c2f9e0409b43b5ca4773cbcc0a30397446cdac1986632c0c5ef4f959bc21fcb99aebcd45283b960dc1 SHA512 a4a69dde7678552b6d5800ee135c5cdee52bb740dfe2d68d502573daaf2fa98cbc946b28b9ec3067da11e8da9a7f4a6580826ff0f6e906ce5172af9b5184109a
+EBUILD cbor2-5.2.0.ebuild 896 BLAKE2B 063f14614963d60c90aabf14f001bf724ad3b135c6e80329dfa6af71632628aa528223c605252b18e52d07394fae67451f5d1feecf23353e054b1bfd517a374b SHA512 cc731c63785f9d929f456553b4c2e2f7e9bfd3e50067cad9def7c08c58e43a0af05f5caa72a4b171ee3058f22abc8b93bf1016de696d19b6d5a590cc81ca91d2
MISC metadata.xml 893 BLAKE2B a56c40664c6526d741a1f4e6be15cb582e0a0402182545262e3f1f489441e94a2c17072c01797e95cbea02d40b2d6addc14027596e4cd2fa49ccb4cb0feadd09 SHA512 1695d3be04f9cb86ea83f3676f5e8628b196b7044bee019ba8ce234500ee1501d013144155fe86ca8f21a10abb35074cd98fbec7da9db7f33c1046229fca9f5e
diff --git a/dev-python/cbor2/cbor2-5.2.0.ebuild b/dev-python/cbor2/cbor2-5.2.0.ebuild
index a423f3fda5a9..2c4aa4f6195e 100644
--- a/dev-python/cbor2/cbor2-5.2.0.ebuild
+++ b/dev-python/cbor2/cbor2-5.2.0.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -11,23 +10,13 @@ DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~x86"
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-RDEPEND="${DEPEND}"
+distutils_enable_tests pytest
python_prepare_all() {
-
# remove pytest-cov dep
sed -e "s/pytest-cov//" \
-e "s/--cov //" \
@@ -36,4 +25,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-distutils_enable_tests pytest
+python_test() {
+ local deselect=()
+
+ if use arm || use x86; then
+ # https://github.com/agronholm/cbor2/issues/99
+ deselect+=(
+ tests/test_decoder.py::test_huge_truncated_bytes
+ tests/test_decoder.py::test_huge_truncated_string
+ )
+ fi
+
+ epytest ${deselect[@]/#/--deselect }
+}